I have tremendous problems using SO today, as almost all javascript-bound links ends up just navigating to the top of the page.

At the same time, the page has this status text:

Waiting for careers.stackoverflow.com...

Is there a problem with hosted javascript files or whatnot these days? These problems have persisted for almost a week now.

If I wait long enough (like, 5+ minutes), or just keep reloading the page (like, 10+ times), the page eventually stops waiting on careers, and javascript again works.

For instance, things I cannot do right now:

  • Vote up/down
  • Moderate

The exact link that never completes is this:


I am unable to retrieve that link in both Chrome and IE.

I am running Google Chrome 14.0.835.186 m on Windows 7 64-bit, and also tested it in IE 9 (9.0.8112.16421.)

  • what browser are you using? is it listed as officially supported here? – gnat Sep 30 '11 at 11:28
  • Additionally, are you able to check what does not load? Can you check if you can reach these servers? – Time Traveling Bobby Sep 30 '11 at 11:30
  • I am using Chrome, latest version (14.0.835.186), on Windows 7 64-bit. The exact url that doesn't load is this: careers.stackoverflow.com/ad/i/fft0hCo-gasp2Lu-g5fWJ0c-12 - It does not seem (to me) that this should have any impact on javascript not executing, but all I know is that javascript code is not executing, so all those "<a href='#'>" links just navigate back to the top of the page. – Lasse Vågsæther Karlsen Sep 30 '11 at 12:15
  • And no, I cannot reach that link. That is, it doesn't fail, it just never completes either. – Lasse Vågsæther Karlsen Sep 30 '11 at 12:15
  • Are you accessing the site from behind a firewall? For some reason some firewalls have real trouble with those bodiless 204 responses. – Tim Stone Sep 30 '11 at 12:24
  • @Lasse - I cannot reproduce; is this still occurring? – Marc Gravell Sep 30 '11 at 12:28
  • I am accessing it at work, can't say I have had these problems from my home network, so I probably am. I tried remoting in to my hosted server, which I know is behind a firewall, and tried a wget on that url. It took 14 seconds to save 0 bytes. Could it help if the site actually returned a length attribute? wget says "Length: unspecified". – Lasse Vågsæther Karlsen Sep 30 '11 at 12:30
  • @Marc, Yes, it still occurs to me. But not from my home network, so i guess this is related to that firewall issue that Tim mentioned. – Lasse Vågsæther Karlsen Sep 30 '11 at 12:31
  • Just to confirm: this has been happening for a week, or just today? Also, are any similar 204 responses not terminating? For example, if you view a question there is a similar 204 response from stackoverflow.com/posts/{id}/ivc/{hash} – David Fullerton Sep 30 '11 at 17:37
  • I have encountered this for "about a week" +/- a day or so. I can't say which sub-requests that have completed or not as I only started digging into this today, and today I've only noticed the links to careers. I don't honestly know which requests end up as 204 or not, and the only requests I see that aren't terminating are the ones going to the /ad/... link on careers, like the one I edited into my question. – Lasse Vågsæther Karlsen Sep 30 '11 at 17:48
  • Also, this only happens at work and on my hosted server, both known to be behind firewalls. At home, I don't have a "firewall" per se, but I do have a broadband router that acts as one, even though it isn't technically a full firewall. At home I don't seem to have any problems at all. However, I could very well see Tim's response extended to mean "some firewalls". I mean, who is not behind some kind of firewall these days? – Lasse Vågsæther Karlsen Sep 30 '11 at 17:49
  • The reason I only started digging into this today is that we've recently migrated domains at work, so I thought it was related to this. All sorts of things have failed to work as expected at work for about a week. However, today I also remoted into my hosted server and I got the exact same problem there, and thus I started testing some more. This server has had no changes for ... months ..., but of course I cannot guarantee that the migration problems at work isn't contributing in some way. – Lasse Vågsæther Karlsen Sep 30 '11 at 17:52


This was related to ESET Smart Security, after an update/new license, which apparently went from only antivirus now to "smart security", including a web scanner, this problem has started occuring.

Since the license is a work license, and I am still only using the antivirus portion at home, I have not had the problems at home.

This has apparently nothing to do with a firewall.

I disabled HTTP scanning in ESET, and SO is now back to working order. If I can find out specifically which setting in ESET created this problem I'll update the answer with more information.

I've filed a support case with ESET for this, seems to be a bug/problem with their software.

  • Hmm, interesting. I haven't had any trouble with ESET Smart Security, but perhaps we have different settings somewhere. Edit: Ah, if you enable active scanning for the browser it starts breaking. – Tim Stone Oct 4 '11 at 14:05
  • Apparently active scanning was on due to a note by someone else here that downloads in Chrome started breaking, ie. being interrupted, just before they completed. I've disabled the entire HTTP scanning module now, seems to be more trouble with it than its worth. – Lasse Vågsæther Karlsen Oct 4 '11 at 14:11
  • good old "smart security"... – Jeff Atwood Oct 4 '11 at 22:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .