When I get a captcha on Stack Overflow, I don't see the image or the input box with Firefox.
I originally had the "HTTPS Anywhere" extension installed but still have the same issue when it's disabled (This caused issues previously when Google's SSL certs were expired for an old domain IIRC).

The requests to Google seem to be never-ending; browsing to the URLs that are still loading results in some pages of JavaScript, but no errors as you'd hope.

The screenshot was taken after the page had been open for more than 3 minutes, and I'm not sure why the GETs are still running. The request popup visible in Firebug is for "GET challenge?k=...."

When browsing to the same captcha page in IE, there are no issues.

I'm aware this could be an issue with my Firefox configuration, as opposed to the site, but would appreciate it if someone could verify if it's just me, and suggest a fix.


  • While visiting the Recaptcha site, I can see a Captcha with no problems
  • If I right-click the problem URLs in FF and Open in new tab, the pages load fine.
  • From the fact that FB omits IP Addresses for the problem ones, I assume that it's not even opening a connection (nor perhaps performing a DNS lookup)
  • Other sites that use Recaptcha seem to work fine (I picked 3 at random from Google)
  • Have you tried in other browsers? Are you behind office proxy that might be blocking certain domains based on black list? Oct 4, 2011 at 14:07
  • @ShadowWizard "When browsing to the same captcha page in IE, there are no issues." - So no, not in at least 1 other browser. No funky network problems - I'm a network admin so completely unproxied/unfiltered for me (and, ofc, it can't be network if IE works). Thanks for the idea though - Any others you have are welcome :)
    – Basic
    Oct 4, 2011 at 19:30
  • What about ping or tracert commands? Maybe they can reveal the bottle of the neck? Oct 4, 2011 at 20:57
  • If I open the problem URLs from Firebug in new tabs, they load perfectly - so it's not a connection issue nor solely a browser issue - FF can load that page it just doesn't seem to do so when embedded in a page. I'm just about to edit the Q to add some more info.
    – Basic
    Oct 4, 2011 at 21:18

1 Answer 1


Try going to


Although to be honest, this sounds like a browser configuration to me if you can't repro it in Internet Explorer. (You could also try Google Chrome).

Have you tried in Firefox Safe Mode?

  • I've had the same problem in Firefox 7 (on Windows 7), and I had to go to IE9 to get around the captcha, since all I could see was the submit captcha button...
    – studiohack
    Oct 5, 2011 at 1:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .