Is there an issue with the Stack Overflow MyOpenID authentication? I can't seem to log in with MyOpenID. I have checked with the MyOpenID authentication logs, and they do get the request which they authorise, but I still get an error stating

Unable to log in with your OpenID provider:

Error occurred while sending a direct message or getting the response.

I have had to create a new account which is really annoying as I have now lost what little reputation I had :-)

  • Is your global inbox working? This may be a bug from a few days ago. – Pops Nov 3 '11 at 15:17
  • I had the same issue around the time this bug was reported, but now that I look at the resolution, I can't tell for sure whether it's the same bug. – Pops Nov 3 '11 at 15:23
  • For the record - the two accounts are stackoverflow.com/users/62338/gary-woodfine (old) and stackoverflow.com/users/847554/gary-woodfine (new) – ChrisF Nov 3 '11 at 15:24
  • I just tried again now and it still doesn't work. To be honest this has been happening for over a month now. It's taken me till today to report it. – Gary Woodfine Nov 3 '11 at 15:55
  • Gary, can you send your OpenID and any other details to team@stackoverflow.com so we can take a look? MyOpenID has a few peculiarities around certain login formats, etc., with more info we can at least ascertain if it's a known issue and let you know what options there are. – Nick Craver Nov 9 '11 at 11:29

I just encountered this bug.

team@stackoverflow.com helpfully offered me a merge account option.

As a last resort, I had a hunch:

My OpenID is of the form http://firstname.secondname.myopenid.com.

MyOpenID seems to do the same thing as Google does, and allows you to login with http://firstnamesecondname.myopenid.com. Stackoverflow could cope with this, so I'm back in business, with no merging necessary.

To avoid this in the future, I've added a login to my account which isn't MyOpenID.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .