4

While I am editing a post (mine or posted by some one other), I cannot see a preview of the markdown. This makes me uncomfortable that I might break the formatting of the post.

Update: After the comments, I figured out there is a link to see the preview, but I am not able to see it.

  1. Try to edit a question.
  2. Now, click on "Show preview"
  3. I do not see the preview.

Browser: Firefox 7.0.1

  1. A 15sec screencast of the problem
  2. On firebug console:

    assignment to undeclared variable preview
    http://cdn.sstatic.net/js/full.js?v=6a19ff0e57e3 Line 1

  • You can't break the formatting of another question. Have you tried upgrading browsers? – Pubby Nov 7 '11 at 21:24
  • Why can't I? Say I am editing some one else's question after they have posted, I edit it. Now, before saving, I should see a preview of the changes. I.e. the way it used to work earlier. – zengr Nov 7 '11 at 21:26
  • What's your browser and have you flushed the cache? – random Nov 7 '11 at 21:28
  • I dont get it. Why is my browser a problem here? I use firefox 7.0. My suggestion is to enable to preview of a post while you are editing it. On stackoverflow, it's disabled. – zengr Nov 7 '11 at 21:29
  • 1
    There should be a preview - immediately below the edit box. The browser might be relevant if there's a bug preventing the preview from appearing. – ChrisF Nov 7 '11 at 21:32
  • 1. Ahh, ic. There is a button for: show preview, but nothing happens when I click it. I will add a bug tag with this question. 2. Can the downvoter please explain the reason for the downvote? – zengr Nov 7 '11 at 21:35
  • 1
    I think people thought you were worried about breaking another question - not the one you were editing. For what it's worth I see a link "hide preview" which doesn't do anything either. – ChrisF Nov 7 '11 at 21:38
  • Updated the question. – zengr Nov 7 '11 at 21:39
  • 2
    I can confirm something is weird with the hide preview button ... probably my class change last week ... will correct it – waffles Nov 7 '11 at 21:50
2

Last week we enabled strict mode in all our JavaScript files, unfortunately we missed one spot where we (me) forgot to declare a var.

Fixed it, for the record, option strict rules.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .