Here's an interesting question on WebApps.SE:

Google Plus links to Stack Exchange questions and answers

It's described as a Google Plus problem, but it may be a server config issue on the SE side. Nothing immediately visible from an inspection of the headers. More details within.

  • 1
    I'm gonna hazard a guess that it's somehow related to redirecting to a URL with a fragment. But note that you can use the full answer URL and it'll work just fine.
    – Shog9
    Dec 27 '11 at 1:46
  • Full answer URL works fine, full question URL works fine. SHORT question URL also works fine and no visible difference between the redirects for short question and short answer. So, a puzzle.
    – Ciaran
    Dec 27 '11 at 2:11
  • The visible difference is in the #fragment, like @Nine already commented. The redirect for the example question Location: /questions/199569/where-to-maintain-central-source-repository versus the troublesome example answer Location: /questions/13267/git-and-mercurial/343603#343603. I'd say it's a Google Plus problem, not understanding 301 Moved with a fragment. Or, maybe there's still no consensus about that?
    – Arjan
    Dec 27 '11 at 8:34
  • I think my brain is malfunctioning a little. Cheers Nine and @Arjan. I thought I had tested the link with and without the fragment and got the same result, but I guess not. Testing bit.ly/ttA6vD [w. fragment] and bit.ly/sE65gN [w/o fragment] displays the observed behavior on G+. So it's a Google thing.
    – Ciaran
    Dec 27 '11 at 10:10
  • (I merged @Nine's findings and our comments into a suggested edit on that answer. My reference to that draft RFC was moot, as that referred to fragments in the original URL.)
    – Arjan
    Dec 27 '11 at 11:07
  • @Nine, I cannot test with Google Plus, but: the other tools fail on the full URL with a fragment too! Like: google.com/webmasters/tools/… yields "empty page" too.
    – Arjan
    Dec 27 '11 at 11:19
  • Google be crazy. @Arjan's link above, once the fragment has been removed, works correctly: google.com/webmasters/tools/…
    – Ciaran
    Dec 27 '11 at 13:15

As per the comments above and the answer here, this is a Google bug and not a SE bug. Thanks to @Arjan and @Nine for the contributions.

  • Still then: as you also showed us that Google cannot handle this when automatically converting full sites for viewing on mobile devices, it might be nice if The Team can somehow create some workaround. But I'm afraid that would require client-side JavaScript (like: don't use the fragment in the 301 Moved redirect, and then when seeing /questions/13267/git-and-mercurial/343603, add the fragment). Not too nice of a workaround, I assume?
    – Arjan
    Dec 27 '11 at 13:47
  • I posted the issue on Google's forums: google.com/support/forum/p/Google+Mobile/… It would be awesome if people can go there and star it so that it gets some attention from the Google moderators. @Arjan, the client-side hack could work - I don't think there's a use case where you would browse to an answer URL and not want to see the answer in question, right?
    – Ciaran
    Dec 30 '11 at 2:47
  • 1
    I'm not sure when, but they fixed it. Follow this link to see the test cases that now work correctly in the Rich Snippets Testing tool: google.com/support/forum/p/Google+Mobile/…
    – Ciaran
    May 21 '13 at 14:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .