5
  • I posted a couple of comments
  • I edited them a couple of times
  • I tried to edit one of them again (much more than 5 seconds had passed)

=> I got the error "You can only comment every 5 seconds".

So I patiently waited about 10 seconds and tried again. => same error

So I patiently waited more than 15 seconds and tried again => same error

Eventually I gave up. Then after a few minutes, I went back to edit my comment, and the "edit" link has even disappeared: I can't edit it any more at all.

By the way I was editing the comments in order to correct/improve formatting

  • 2
    Did you try simply refreshing the page? Did you just post a new, clarifying comment? Do you have a link to the comment in question? – Andrew Barber Jan 2 '12 at 21:01
  • I'm not sure whether i tried refreshing the page. No I didn't post a clarifying comment, I didn't deem it worth it (I was just trying to correct the formatting). The link to the comment is this: stackoverflow.com/questions/2501704/… And by the way I was wrong about the formatting help, i was just desperately trying to put some line breaks in it :P – matteo Jan 3 '12 at 16:58
  • Copy/paste the content to a new comment, delete the old comment, and fix the formatting in the new one. You'll lose your place in line, but that's the way it works. – Kevin Vermeer Jan 3 '12 at 17:18
  • Are you still noticing this issue? – kiamlaluno Sep 25 '12 at 0:04
  • Gonna try. Fourth edit.... seems it works now – matteo Sep 25 '12 at 8:07
  • @kiamlaluno seems it works fine now. Now if 5 minutes have passed from the posting of the comment, I get the error "Comments can only be edited for 5 minutes" (expected), so I guess the problem was that the wrong error message was being shown, and it seems to be fixed. – matteo Sep 25 '12 at 8:16
  • Seems to be happening again in Chrome on Stack Overflow. – NetMage Mar 14 '17 at 21:49

You must log in to answer this question.

Browse other questions tagged .