I'm getting the following prompt when browsing around the network. I'm using Firefox 6.0.2 on Windows XP.

enter image description here

Update Hmm seem to just be getting on meta now.

  • Are you behind a proxy server? Mar 1, 2012 at 21:11
  • 2
    @Daniel Yes, I'm at work. They must be on to me!!! :)
    – Doug T.
    Mar 1, 2012 at 21:27
  • 11
    Try authenticating with the credentials JoelSpolsky password Smart and gets things done!. The old credentials JeffAtwood password ~Six to eight weeks expired today.
    – Pollyanna
    Mar 1, 2012 at 21:35
  • Do you use Firefox? Do you have need to use a NTML proxy? Apr 3, 2012 at 7:29
  • I'm seeing the same issue since today, see also here for similar issues: meta.stackexchange.com/questions/123648/… and meta.stackexchange.com/questions/127981/…
    – nwinkler
    Apr 20, 2012 at 8:48
  • Same problem for me, with a Firefox 12, behind a corporate proxy. A few weeks ago i hadn't that problem, now StackOverflow is really hard to browse with this authentification required popup that appear continuously. With the Live HTTP headers firefox plugin, i saw indeed that the url was "sockets.ny.stackexchange.com", so i put that in my Firefox network proxy exclusions (and that way i can browse the site again).
    – Sergio
    May 2, 2012 at 11:49
  • Exactly the same problem here. I'm behind a corporate proxy in a bank in New Zealand. Popup appears in latest FF 14.0.1 and everything is fine in IE7. No other website produces such a prompt in FF. Yes, I was able to fix it by putting "sockets.ny.stackexchange.com" in the network proxy exclusion list. Thank you for the solution Sergio! However, stackexchange should investigate - users should not have to do this - and there are many many of us in exactly the same boat - corporate firewall + FF.
    – alex
    Aug 6, 2012 at 20:32
  • 1
    Since we've moved to wss:// (secure websockets) only, this should be a thing of the past. May 22, 2017 at 19:20

4 Answers 4


We were having the same issue with Firefox 13. We were getting the prompt from moz-proxy and then from our proxy server when a page we attempted to connect to referred to sockets.ny.stackexchange.com

We were able to resolve it by disabling "NETWORK.WEBSOCKET.ENABLE" in the firefox config (about:config in the address bar). http://www.adamkoch.com/2012/05/04/moz-proxy-issues/

Update: Firefox has 4 options under network settings for proxy: HTTP, SSL, FTP, and SOCKS. Forcing SOCKS through the proxy is what corrected double prompts (one from Firefox and one from the proxy). If you cannot edit your Firefox Proxy settings, ask the IT staff to add socks to the proxy config. This is a better Enterprise solution that can be deployed by AD or PC Support team.

  • Turning off websockets worked for me too.
    – Bryan
    Aug 9, 2012 at 17:56
  • this fixed it for me also
    – Nimchip
    Aug 9, 2012 at 20:07
  • This worked for me too, thanks!
    – deaks
    Mar 13, 2013 at 2:47

This is caused by a proxy or something in your local config (firewall, antivirus, etc) that is intercepting the traffic. It thinks we are bad, and we are not. Trust us. Really! (:

To verify that this isn't us, you can use the test page here. This will likely show the same issue and is outside of our control.

You are also using a very old version of Firefox, so upgrading that would be a good thing anyway and might have an effect on this.

  • yeah upgraded FF, same problem. Yes I'm behind a proxy at work.
    – Doug T.
    Mar 1, 2012 at 21:30
  • What type of proxy are you behind? I have a feeling your traffic is being intercepted by an active state firewall which doesn't allow sockets unless your system admin enters credentials - any ideas? Mar 1, 2012 at 21:37
  • 5
    <obligatory backwards smiley vs. trust joke>
    – Tim Stone
    Mar 1, 2012 at 21:56
  • 1
    @Doug Not only are you using an old version of Firefox, you're also using a very old version of Windows. And probably an old computer, too. Try upgrading those and getting back to us. ;-)
    – Cody Gray
    Mar 2, 2012 at 2:32
  • @CodyGray I wish I had control of any of those. Didn't you hear, FF 6 is the new IE6?
    – Doug T.
    Mar 2, 2012 at 11:17
  • @GeoffDalgas All I know is its a web proxy that all Internet traffic goes through. Specifically I work for a subsidiary of very large US airplane manufacturer megacorp that just came out with a new 3 digit commercial jet.
    – Doug T.
    Mar 2, 2012 at 11:20
  • @GeoffDalgas It might have just gone away by me just filling the prompt out with something (user name:"no",password:"no"). I'll see if it stays gone and if so post that as an answer.
    – Doug T.
    Mar 2, 2012 at 15:09
  • 1
    @DougT. I just noticed this issue as well--same firewall I think. Entering a bogus user name and password worked for me as well, thanks!
    – G. Stevens
    Mar 10, 2012 at 23:15
  • I'm having the same problem at another subsidiary of very large US airplane manufacturer megacorp that just came out with a new 3 digit... hey, wait a minute... hi Doug! Anyway, I'm still having this problem on FF10. What am I supposed to do, enter my SE login info in that dialog? Is that why it's appearing? Mar 13, 2012 at 15:15
  • 1
    Getting this too in a large UK investment bank. What's most frustrating is that it prompts 6 or 7 times before finally giving up. I tried the bogus user name/password to no avail. Apr 3, 2012 at 9:52
  • Same problem on my side. Why it started appearing few weeks ago? Have stackexchange guys started using some new api? Apr 10, 2012 at 9:21

I am behind "web washer" proxy and Doug T's solution did not work for me as the prompts continued. The issue is specific to FF since IE 9 doesn't support sockets.

I was able to avoid the prompts by adding sockets.ny.stackexchange.com to the "No proxy for:" field in Firefox. So far no ill effects.

  • This was the best solution for me.
    – Meryovi
    Jul 26, 2012 at 12:01
  • both websockets solution from Neobane and this one worked for me although I prefer the latter so I don't have to disable websockets for everysite.
    – danirod
    Aug 21, 2012 at 11:47

Yes it does appear to be a corporate firewall issue. What seemed to work for me was to just enter a bogus username/password and I don't get bothered anymore. The sites all seem to continue work ok.

  • 4
    Those are the worst kind of corporate firewalls. We had one like that at GE that used HTTP Basic Auth. Anyone who found out what the Realm said could duplicate it, potentially stealing single sign on usernames and passwords if they had their website pop up the same auth! After a number of us raised concerns they changed it out. Please raise this concern with your corporate security.
    – user7116
    Mar 11, 2012 at 1:09
  • 1
    This seemed to work for me too (same network as Doug). Mar 13, 2012 at 15:19
  • I locked myself out of my AD account several times because of this (had an old password stored in FF). Entering the correct password doesn't seem to work. Jun 19, 2012 at 12:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .