0

Possible Duplicate:
Edit Comment link breaks when I edit a comment and then press [enter] to save

I'm seeing incorrect behavior with regard to an edit link on a comment to a question. I suspect that this may also be an issue for edit links for comments on answers.

If I click on the edit link the first time, I go into edit mode, and can make changes. I click 'Save Changes', and it updates the comment, and gives me back the edit link. If I attempt to click it again, nothing happens. I am not presented with a textarea to update the comment.

This is under IE 9.0.8112.16421. Can anyone reproduce?

marked as duplicate by Adam Lear Mar 8 '12 at 19:50

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @Martin: Haven't tried any other browsers to see if it's actually an issue in all of them... have you tried another? – Lynn Crumbling Mar 8 '12 at 16:17
  • No repro here in Chrome and IE9. Try clearing your cache and/or refreshing the page. – Adam Lear Mar 8 '12 at 16:17
  • @AnnaLear Refreshing the page definitely fixed the issue; I suspect the ajax was somehow busted for me on the second click attempt, almost like the click handler event never got bound – Lynn Crumbling Mar 8 '12 at 16:27
  • Odd. Glad to see it fixed itself. :) – Adam Lear Mar 8 '12 at 16:30
  • I have seen this, and I can reproduce it consistently in IE 9. – Szabolcs Mar 8 '12 at 18:57
  • @Szabolcs: since you can also reproduce, I've flagged this and requested reopening, noting that after I refreshed the page, even though it temporarily fixed it, it broke again immediately. – Lynn Crumbling Mar 8 '12 at 19:05
  • @Szabolcs: can you repro it under any other browsers? – Lynn Crumbling Mar 8 '12 at 19:06
  • See this bug report. – Tim Stone Mar 8 '12 at 19:15
  • @TimStone: Excellent. Thank you for the follow-thru. I'll bet Anna wasn't able to repro it because she was using the mouse instead of hitting enter.. never even occurred to me that there might be a difference. Either way, nice to know there's a bug lodged. – Lynn Crumbling Mar 8 '12 at 19:19
  • @LynnCrumbling I marked this as a dupe of the existing report. I don't think I used the mouse, but I can repro this in IE9 now (but not in Chrome). – Adam Lear Mar 8 '12 at 19:51
  • @AnnaLear Great to know, and thank you for taking a look at Chrome. – Lynn Crumbling Mar 8 '12 at 20:33

Browse other questions tagged .