My work internet connection runs behind a proxy with pretty standard filtering to keep us away from watching silly videos on youtube all day. I'm running Firefox 11 on Windows and it is configured to automatically use the system network proxy settings.

Lately I've been getting "Authentication Required" proxy dialogs from the browser whenever a page on Stack Overflow, Meta SO, Server Fault, etc loads. The page content itself displays, but then some sort of active content on the page fires and needs proxy authentication. Inputting credentials does not make this go away. It started of with one or two dialogs per load about a month ago, went down to none on SO last week, and as of today is up to 6-8 requests.

Based on the Similar Questions, it appears to be something to do with WebSockets. I have tried entering both accurate credentials and bogus credentials as suggested in other questions, to no avail.

These dialogs make for a brutal browsing experience to the point that I'm unlikely to visit the site for actual work problems. The issue only seems to affect Firefox. No troubles with Chrome or IE7. Can this be fixed? Is there some way I can turn off the active content for myself?

  • Awesome, downvote without any comment. – Ophidian Apr 3 '12 at 14:22
  • 1
    Maybe just use Chrome? SO can't really do anything about your filter proxy configuration. – Ghost User Apr 3 '12 at 14:25
  • 2
    I think it was downvoted because the problem seems to be your IT-Department and your Proxy, not SE. – Time Traveling Bobby Apr 3 '12 at 14:29
  • 1
    @Ophidian is there any way you can capture your traffic with fiddler or wireshark when using firefox and email it to team@stackoverflow.com? I'd be interested to see what is going on here since it has been reported at least one other time. – Geoff Dalgas Apr 3 '12 at 14:35
  • 1
    I wouldn't call this kind filtering "pretty standard". Contact your IT department and request them to white-list Stack Overflow and Stack Exchange in order for you to be able to access information related to your job (you are programmer aren't you?) Suggest them this question as an example URL to verify that their filtering is corrected – gnat Apr 3 '12 at 14:47
  • @GeoffDalgas I'll see what I can do, appreciate the help. – Ophidian Apr 3 '12 at 14:52
  • Any update on this? I have the same problem on SO (and here as well) since this morning, and I'm no longer able to use the site in Firefox anymore. Safari works fine. – nwinkler Apr 20 '12 at 7:28
  • Usign Firebug, I can see that the request is going out to the following server: sockets.ny.stackexchange.com When opening this URL in Safari, it comes back with a Zero Size Object message. The request seems to be coming from a file called full.js and seems to be Websocket related. – nwinkler Apr 20 '12 at 7:44
  • Extensive delay going back and forth with IT to make sure they weren't going to freak out about the packet capture being sent. It got sent this morning. – Ophidian Apr 20 '12 at 14:52
  • Wow, this needs to be a sticky somehow, or SE needs to add some sort of notification that web sockets are not working properly (when supported). – kakridge Jun 13 '12 at 12:54

This isn't necessarily a solution but it is a work-around that may be helpful for others. There are 5 possible Proxy settings in Firefox (11.0):

  1. No proxy
  2. Auto-detect
  3. Use system proxy settings
  4. Manual proxy configuration
  5. Automatic proxy configuration URL

I was seeing the issues with both System proxy settings and Automatic proxy URL. When I set the proxy configuration manually and checked the Use this proxy server for all protocols box, the dialogs stopped popping up. The IT guys and I went back and confirmed that we're getting the same proxy URL/Port from the configuration URL, so I'm entirely unsure why this one is working. May be helpful to others, I'd be curious to know their results.

| improve this answer | |
  • Had the same problem on the SE sites and this worked to fix it. Basically just copied over the settings from the system wide proxy into manual proxy configuration for Firefox. Also make sure to copy over the exceptions from the system proxy settings to the Firefox exceptions. We had these exceptions setup for some of our internal web pages and they failed to load until I added these exceptions. – Praneeth May 3 '12 at 14:35
  • Thank you! This had been driving me nuts for a while, to the point where I had pretty much using SE sites at work. Problem solved. – MetalMikester May 10 '12 at 11:49
  • I initially added a hosts file entry to loopback sockets.ny.stackexchange.com, but your tip worked. Thanks! – kakridge Jun 13 '12 at 12:54
  • Ugh, now I get AD prompts on my intranet. Two options, add selective proxy bypass lists (pain) or go back to loopback approach (I suppose I lose real-time notifications on SE pages). I guess I'll go with option 1. – kakridge Jun 13 '12 at 14:48

This problem will be most prevalent in Stack Exchange sites because they use Websocket. Firefox cannot figure out how to handle this with the authentication token, so it asks you to do it. To fix it, your IT needs to force SOCKS through the proxy. Most of the time they just configure "HTTP" and nothing else.

You can manually set this in Firefox if your IT has not locked you out of your network settings. Click on Tools > Options > Network Tab > Settings in the Network Box. You will see options for setting proxy servers for HTTP, SSL, FTP, and SOCKS.

| improve this answer | |

This problem can also be addressed by browsing to about:config and setting network.websocket.enabled to false. That did the trick for me. I've seen elsewhere that network.negotiate-auth.allow-proxies false would work as an alternative, but I haven't tried that.

| improve this answer | |
  • Setting dom.workers.websocket.enabled to false worked for me (Firefox 36.0a2). – WynandB Dec 7 '14 at 21:06
  1. Install Firebug
  2. Install NoScript
  3. Go to the problematic website
  4. Check errors in Firebug
  5. Block the annoying parts with Noscript

In my case this problem seemed to be related to the FoxyProxy addon as it doesn't occur in IE when I switch proxies manually. Apparently the alternate proxy wouldn't allow google analytics SSL connection.

Firebug noted these errors:

"NetworkError: 407 Proxy Authenticatio... ( Access is denied.  ) - https://ssl.google-analytics.com/ga.js"
"NetworkError: 407 Proxy Authenticatio...xy filter is denied.  ) - https://ssl.google-analytics.com/ga.js"

On the NoScript menu, I chose the option to "Mark google-analytics.com as Untrusted", and the proxy auth dialogs stopped.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .