11

With the new asynchronous question updating (which is great, btw), there's a feature to show new answers to questions without reloading the page. With the established user privilege, users can click an answer's vote count, and see the breakdown of up and down votes.

However, this feature is unavailable on the asynchronously loaded answers.

Screenshot taken after an answer was automagically loaded -

enter image description here

As you can see, the mouse pointer does not indicate a clickable element.


To reproduce:

  1. Be an "established user" (1000 rep or more)
  2. Load a question
  3. Wait for a new answer to be posted, when the message "1 new answer to this question" (or similar) appears below the question
  4. Click to load the new answer
  5. Click the vote count to view the up/down vote breakdown on the new answer.

If you don't like waiting, then

  1. Be an "established user" (1000 rep or more)
  2. Load a question
  3. Open the formatting sandbox in two tabs
  4. Post an answer in one tab
  5. Click to load the new answer (in the other tab)
  6. Click the vote count to view the up/down vote breakdown on the new answer.

Expected behaviour: Up and down vote count displayed in place of total vote count

Actual behaviour: Nothing (After some time, the votecount becomes clickable)

The vote count feature still works correctly on answers loaded at the time of the page load (so you can refresh the page if you really want to see the voting breakdown).

10
  • Trying to reproduce... Taking me a little time to reach 1K ;)
    – Lix
    Apr 10, 2012 at 11:34
  • Ha! Took some time, but yep... I can reproduce this... Chrome 18 on Ubuntu 10.10...
    – Lix
    Apr 10, 2012 at 11:35
  • 1
    Thanks for the freehand circles Lix! Apr 10, 2012 at 11:57
  • 1
    My pleasure! Don't let anyone tell you that they went out of style!
    – Lix
    Apr 10, 2012 at 11:58
  • 1
    Extremely strange. It's unclickable alright, BUT, for some reason, if you wait long enough, it becomes clickable. Apr 10, 2012 at 12:06
  • Damn my impatience! What @man says is true... It becomes clickable after a few seconds.
    – Lix
    Apr 10, 2012 at 12:12
  • 2
    I've added an alternative way to repro, along with the wait-long-enough thingy, since it's been repro'd. Apr 10, 2012 at 12:16
  • @Manishearth Thanks :) Apr 10, 2012 at 12:33
  • "Actual behaviour: Nothing (After some time, the votecount becomes clickable)" so the bug only lasts short time? Since new answers start with 0 votes, getting the vote count immediately isn't very useful. Maybe the delay is intentional?
    – yoozer8
    Apr 10, 2012 at 14:14
  • @Jim: Answers that new to the page load may not actually be new time-wise - for example on question pages loaded some time ago, the "new" answers often already have several votes. I regularly see answers with 2-3 votes load this way. (I haven't actually seen the "after some time" behaviour - others edited it in to the question for me. Although, I'm sure they're not making it up ;) Apr 10, 2012 at 14:38

1 Answer 1

5

Thanks for this report. The vote split init was not working due to the fade in animation during loading of a new answer. The vote split init has been moved and not fired until after the answers are fully displayed. This will be fixed in the next build.

1
  • You're welcome. Glad it sounds like an easy fix :) Apr 11, 2012 at 13:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .