I just tried to improve a question by simple adding some whitespace to the code parts. The edit was rejected with the comment that I made no changes. Only after I additionally removed the text at the end ("Thanks in advance") I was allowed to save my edit.

I think this is a bug, because adding whitespaces in this case lead to a dramatic increase in readability.

  • Your edit clashed with another one, by the way. – Time Traveling Bobby Apr 11 '12 at 13:02
  • @Bobby: Not really. The edit that happened afterwards was submitted 8 seconds after I submitted mine. That was at least 30 seconds after I received the message. So that couldn't have been the reason for the rejection. – Daniel Hilgarth Apr 11 '12 at 13:04
  • No, was just notice so that you know that some of your changes have been reverted. – Time Traveling Bobby Apr 11 '12 at 13:06
  • @Bobby: OK, thanks. I misunderstood your comment then. – Daniel Hilgarth Apr 11 '12 at 13:07
  • Should this be a feature-request where you argue that whitespace should be included in the characters-changed count (to get you over the threshold of 6)? – Scott C Wilson Apr 11 '12 at 13:13
  • @ScottWilson: Well, I think it is a bug, that they are not counted. But if it was a conscious decision I guess it really is feature-request... – Daniel Hilgarth Apr 11 '12 at 13:20
  • 1
    "Only after I additionally removed the text at the end ("Thanks in advance") I was allowed to save my edit" - seems like it's working perfectly ;) – user159834 Apr 13 '12 at 3:16
  • @WesleyMurch: I don't follow – Daniel Hilgarth Apr 13 '12 at 5:00

I tried editing the question you are referring to add four spaces, and my edit has been accepted.


I then reverted the edit I did by removing the four spaces I added; as I did that in the grace period, there isn't track of the edits I did.

Once you get the privilege of editing every post, you can add a single character, or add 6 spaces to a post; it's just the users who don't have the privilege of editing every post that have those restrictions for their suggested edits.

The message you have seen could be the one saying that somebody else already edited the post you were editing, which appears even in the case somebody else suggested an edit. It happens also when you started to edit the post, but you clicked on the button to save the changes after a (suggested) edit has been completed.

Looking at the revision page for that question, I notice that the OP edited the post at 12:56:55 pm, while your edit was done at 12:56:47 pm. This means the OP started to edit the post after you started, but before you ended your edit.



In such cases, Stack Exchange gives you a message; the usual one I see is the following one:

This post has been edited 1 time since you began. Your edit can only be saved if it is more thorough than the currently saved edit.

The message appears when I am editing the post, on the bar at the top of the page, in the same position other notifications are shown.

I am sure you can edit a single character in a post, as that is what I have done many times, in Stack Exchange sites where my reputation allows me to edit any post. Your reputation on Stack Overflow is higher than the reputation required to edit any post, and that allows you to change even a single character, or add a single character, whatever that character is a space, or not.

  • Thanks for the test, however I am not sure I completely follow your answer: (1) I have nearly 32k rep, that should be enough to edit every post (2) I didn't see a suggested edit before or after my edit (3) The message I saw was not the one you get if someone else did a parallel edit. The one I received was different from that. – Daniel Hilgarth Apr 11 '12 at 13:37
  • You didn't see any suggested edit before because the edit was not suggested before you started to edit the post; once you edited the post, if there were a pending suggested edit, your edit automatically approved the suggested edit. I am just supposing what could have happened; for sure, as your reputation is higher than 5,000, you can change a single character in a post. – kiamlaluno Apr 11 '12 at 15:42
  • It was not a suggested edit, but the edit done from the OP, who doesn't need to suggest edits for his/her own posts, independently from the reputation the user has. – kiamlaluno Apr 11 '12 at 16:37
  • If the edit by the OP really was the reason, the message I got was HIGHLY misleading. It didn't say anything about another edit, it just said something along the lines of "It looks like you are trying to improve the question but you made no changes". – Daniel Hilgarth Apr 12 '12 at 8:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .