4

I attempted to edit the title of Using Global variables in Threads in Python to fix a typo in the title. Unknown to me, somebody else with insufficient rep to commit an edit was already making the same change.

When I clicked the "edit" link I did not see the pending edit but was presented with the normal edit UI. When I tried to commit the change I got the "You seem to be improving a post but haven't made a change" message.

I tried several times and never saw the pending edit.

At this point (still unaware of the pending edit) I came over to meta to see if anybody else had reported this and found a post which clued me in.

I went back to SO and tried to edit again, and still got the same behavior. It was only when I finally refreshed the page that I saw the edit(0) notation.

In case anybody's interested, here's my analysis:

  1. I started to edit at nearly the same time as the other user; both of us saw the normal edit UI.
  2. The other user committed first
  3. When I tried to commit, the validation logic assumed I came from the "improve an edit" UI and gave me what it thought was an appropriate message. When I dismissed the error box I saw the original post with the typo.

I know this is a low-probability race condition (well, maybe not THAT low) so I thought I'd report it.

Tagging as a bug, but I understand if this isn't considered important enough to fix.

You must log in to answer this question.

Browse other questions tagged .