34

The corporate proxy at my work doesn't support web sockets and as I understand, as informed by Wikipedia, this is pretty common.

Whenever a Stack Exchange page loads, in Firefox, I have to click through six proxy authentication messages before I can do anything.

It doesn't look like Stack Exchange uses websockets on other browsers.

While others in a similar situation and I can just use another browser, it would be useful if Stack Exchange can disable websockets for a session if they're failing.

12
  • Are you asking SO to change their site? Maybe make your request clearer
    – simchona
    Apr 23, 2012 at 1:05
  • Maybe we should just send hate mail to your corporation until they change their proxy setup :) Apr 23, 2012 at 1:07
  • believe me, I've begain. I just jumped over to using chrome so no worries, but was thinking that it must be pretty common.
    – Dan Lord
    Apr 23, 2012 at 1:15
  • @simchona does that read better?
    – Dan Lord
    Apr 23, 2012 at 1:23
  • 1
  • 1
    Also, you should get WebSocket support in Chrome as well...maybe it's just failing more gracefully after getting the authentication response than Firefox.
    – Tim Stone
    Apr 23, 2012 at 1:47
  • 3
    I would go with adding extra option in the Preferences page (http://meta.stackoverflow.com/users/preferences/[user id]) in addition to Allow email notifications when I subscribe to questions or tags we can have there something like Allow live updates through web sockets Apr 23, 2012 at 7:58
  • +1, or worse your corporate proxy uses HTTP Basic Auth. Thankfully ours has moved to a page-redirect (annoying in some cases with images from different domains).
    – user7116
    Apr 23, 2012 at 14:30
  • 1
    Speaking on behalf of IS groups everywhere, may I say "you're doing it wrong". Companies who have decided to use proxy servers would be INSANE to allow websockets the way stackexchange is doing it.
    – Jason Haar
    Oct 10, 2012 at 23:22
  • 3
    Try again... The client uses a CONNECT call to sockets.ny.stackexchange.com:80 - that should never be allowed via a proxy. Allowing software to call HTTP (port 80) webservers via CONNECT methods means you've thrown out all your security controls: no more AV checks, no content filtering - all that good stuff companies like using proxies for. The proper fix would be to run sockets.ny.stackexchange.com over HTTPS on the standard port 443 - then CONNECT statements would work. i.e. by default most proxies block CONNECT attempts to port 80.
    – Jason Haar
    Oct 10, 2012 at 23:34
  • 1
    Agree - this is quite irritating .. Even i noticed it lately. Will try the suggestions recommended
    – gnlogic
    Nov 29, 2012 at 5:59

3 Answers 3

16

It is possible to completely disable WebSockets in Firefox (in about:config put network.websocket.enabled to false).

This will solve the issue without touching the proxy settings.

5
  • 1
    +1 for this! This issue has been driving me absolutely nuts! Jul 24, 2012 at 21:42
  • I would like to confirm that this is one of two ways to correctly fix the problem. Either tell Firefox to not use websocket. Technically, the problem is that HTTP is forced through the proxy while SOCKS is not. If they can, the IT needs to push a setting through AD to force Firefox's SOCKS connection through the proxy. You can manually do this by typing in about:config then set network.proxy.socks to the proxy server ip and make sure the port is set for network.proxy.socks_port. We use port 80.
    – Neobane
    Aug 15, 2012 at 13:03
  • 2
    It looks like the setting network.websocket.enabled isn't available in Firefox 35+ anymore. It worked for my in Firefox 15. But modern Firefox versions don't have that configuration. Apr 12, 2015 at 9:18
  • You are right, this setting was removed: bugzilla.mozilla.org/show_bug.cgi?id=1091016
    – user190785
    Apr 19, 2015 at 17:28
  • Please see my answer for a workaround. Jul 28, 2015 at 21:06
5

I had the same problem on Firefox, what worked for me was adding an exception on my proxy settings for sockets.ny.stackexchange.com that way it just fails silently for that address instead of asking for authentication.

2
  • Since this morning, I wasn't getting just 6 authentication requests, it was just looping, continually, on all tabs. This 'fixed' that problem, at least...
    – Benjol
    Jul 19, 2012 at 13:20
  • I had the same problem today, but with the address sockets-se.or.stackexchange.com. Firebug helped in finding the offending address. Nov 6, 2012 at 8:36
4

Now that Firefox has removed the preference that would allow a user to disable WebSockets, I decided to tackle this problem on my own and wrote WebSocket Disabler — a Firefox add-on that does exactly what its name suggests.

After installation, it adds a menu item to the Web Developer menu that can instantly enable or disable WebSockets:

enter image description here

1
  • Only solution that worked with FF 39. I wonder how the other browsers get around this problem as I neither have this issue on IE nor Chromium...
    – Jan
    Aug 5, 2015 at 14:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .