I am using OpenID (MyOpenID) to login to Stack Overflow and other Stack Exchange websites. But sometimes, I get an error message saying:

Unable to login with your OpenID provider: No OpenID endpoint found.". Below is the screenshot.

What causes this error?

Enter image description here

  • What does test-id.org/OP/Sreg.aspx report?
    – Flexo
    May 8 '12 at 10:06
  • Same for me, test-id.org gives the same error: Login failed: No OpenID endpoint found. myopenid.com is slow and sometimes unresponsive.. maybe a problem on their end?
    – user185346
    May 8 '12 at 17:27
  • Only sometimes I get the error. Next time when it fails, I will test it. This time it loads myopenid.com.
    – user152028
    May 8 '12 at 18:00
  • It finally let me in.. seems to be intermittent.
    – Mike B
    May 8 '12 at 19:11
  • same here - it doesn't work the whole day for me - definitely on their end I'd say
    – NSGaga
    May 9 '12 at 17:03
  • Now I get Login failed: No OpenID endpoint found after testing with myopenid.com for chemistry.stackexchange.com/users/authenticate. I think the problem is with their website.
    – user152028
    May 9 '12 at 17:34
  • In future, use this link
    – user1228
    May 11 '12 at 14:59

This is a problem on the MyOpenID end of things. They seem to be getting progressively worse.

We recommend you add another OpenID provider to your account and login with them... Accordingly, we've demoted MyOpenID from being a recommended provider.


I had the same error - you must use https://www.myopenid.com/. This worked for me :-)

You must log in to answer this question.