This past week, I have noticed that the WYSIWYG editor has disappeared when I am at work. This is happening on SO but not on meta. This behavior is happening in all browsers that I have access to (IE, Chrome, Firefox).

I found another question on meta with the problem but no solution was posted, I tried all of the suggestions but nothing worked.

I think I have figured out the problem - it looks like my company has blocked the URL of the script for the WYSIWYG -- http://cdn.sstatic.net/js/wmd.js?v=dcfaf6cb7e9c

Any suggestions to get the WYSIWYG back? My company states that the cdn.sstatic.net is a Malicious site and has been restricted for use - I guess I spend too much time on SO.

Does meta use a different location of the script?

One more strange thing, whenever I try to post an answer at work it always presents me with the Are you Human question.

  • Are you behind a proxy? If so, can you tell us which vendor? – Nick Craver May 10 '12 at 14:49
  • @NickCraver I honestly don't know. My company will block any/all sites that they feel are inappropriate for work. – Taryn May 10 '12 at 14:52
  • 3
    @bluefeet - in this case it's likely pulling from a malware/virus list that includes a false positive for wmd.js...no one in your company likely blocked this URL...but we need help in tracking down what list these things are pulling from, so we can get it updated and remove that false positive. – Nick Craver May 10 '12 at 14:53
  • 1
    @NickCraver I will see if I can find out what triggered it. – Taryn May 10 '12 at 14:55
  • 1
    @bluefeet - Thanks, if you can provide any info at all, it'll help us fix this for everyone affected. – Nick Craver May 10 '12 at 14:56
  • @NickCraver not sure if this helps but we use McAfee SmartFilter and the URL is categorized as Malicious Downloads thus it is blocked – Taryn May 10 '12 at 14:58
  • @bluefeet - definitely helps, thank you. I'll update this when we have some movement on it, contacting those who can fix this momentarily. – Nick Craver May 10 '12 at 15:00
  • Cool thanks for the help, let me know if you need any additional info – Taryn May 10 '12 at 15:01
  • I experienced this too last week Missing toolbar and not getting any preview of posted answer. The problem went away over the weekend. – LarsTech May 10 '12 at 15:03
  • @LarsTech looks like it might be a similar issue, that is definitely part of my problem, no WYSIWYG/preview and it presents me with the are you human check before posting an answer. – Taryn May 10 '12 at 15:10
  • possible duplicate: meta.stackexchange.com/questions/131836/… – gnat May 10 '12 at 15:11
  • please tell me it isn't the name 'wmd' they're objecting to... – Flexo May 10 '12 at 15:38
  • Try shift-f5... It worked for me on FF.. – Manishearth May 10 '12 at 15:54
  • @TimManishEarth doesn't work, the script is being blocked – Taryn May 10 '12 at 16:00
  • What shift-f5 does (seems it was remapped to something else)? – Fabricio Araujo May 10 '12 at 16:06

So this was a false positive by McAfee (that filtered down to workplace proxies and filters), we pinged them with the relevant info and got it removed from their malicious list. Here's that email response:

Hello Mr. Craver,

Thank you for bringing this error to our attention.

The categorization of this URL will be corrected as Technical Information.

The control list with the correction stated above will be available for download from our public download servers in a few hours. (If it is marked CURRENT, then this correction is already in the control list.) We are sorry for any inconvenience because of this site being incorrectly categorized.

Depending on the control list download schedule for your organization, you may not see this site categorized, as stated above, until a later date. Please contact your network administrator for control list download schedules.

Thank you.

Trusted Source Web Database
Customer Response Team - North America
McAfee, Inc.

Expect this to resolve itself as those definitions are pulled to the proxy/filter at your workplace, hopefully within the next day.

  • 2
    awesome, thanks for following up on this. It has been a very frustrating week and I almost didn't post this on meta because I thought it was just me. – Taryn May 10 '12 at 18:31
  • Do they provide any insight has to how you got onto their list, and how to avoid it happening again? – Benjol May 11 '12 at 6:01
  • @Benjol - unfortunately not, I assume they reveal as little as possible to protect their detection mechanisms...which are hopefully a bit better as the result of this. – Nick Craver May 11 '12 at 11:13
  • 1
    I expected as much. WP "The company also developed filtering systems used by governments such as Iran and Saudi Arabia that blocks their citizens from accessing information on the Internet." Nice to know my company loves and trusts me too :P – Benjol May 11 '12 at 11:22
  • @NickCraver this issue is now resolved at my work. Thanks again for the help. – Taryn May 11 '12 at 11:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .