RESOLVED: I am not sure why this worked but I did a reboot of my entire network, computer, and everything as a last ditch effort. Must have had some setting that somehow blacklisted my Mac from making any connection to cdn servers.

Thanks everyone for the assistance; without the guidance I never would tried what I did to get it working.

I didn't have enough rep to post the answer to my own question.

QUESTION: I tried searching for this issue but was only met with questions of people who are actually experiencing a 'stack overflow' error.

Recently as I have been doing my dev work on my Mac, I had noticed that the Stack Overflow website stopped working for me. I am still able to go to all other websites but when I navigate to Stack Overflow it will either hang and never load or will display an unstyled version of the content and it is super slow.

To make sure that that the problem was me, I checked the website on both my phone and my tablet and they appear to be functioning fine. I have also tried clearing the cache and using different browsers but have not yet had any luck.

Stack Overflow is amazing and I would love to continue to be able to use it again on the computer that I have been doing all my dev work. Any suggestions on what to try would be greatly appreciated.

This is what I am seeing:

enter image description here

Edit: After checking the chrome developer tools, I was confronted with the following errors:

Failed to load resource http://cdn.sstatic.net/careers/cso/all.css?36c9ba

Failed to load resource http://cdn.sstatic.net/careers/Js/all.min.js?36c9ba

Failed to load resource http://cdn.sstatic.net/careers/Js/third-party/jquery.form.js?36c9ba

Failed to load resource http://cdn.sstatic.net/careers/Js/jobs.min.js?36c9ba

Failed to load resource http://cdn.sstatic.net/careers/Img/logo-careers-2-so.png?36c9ba

Failed to load resource http://cdn.sstatic.net/careers/Img/home/intro-slogan-candidate.png?36c9ba

Failed to load resource http://cdn.sstatic.net/careers/cso/all-print.css?36c9ba

Any idea what I could do to get access to these resources?

  • I get this same error from time to time and haven't found a fix yet. Sometimes restarting the browser solves the issue. Some other times I have to wait a few days for stackexchange to work again. It only happens from my office computer though, so it may be related to the firewall.
    – algiogia
    Commented Sep 24, 2015 at 10:01

1 Answer 1


It looks like you're not downloading the stylesheet or one of the script files properly, have you changed your firewall/anti-virus/etc?

Try navigating to: http://cdn.sstatic.net/ - if you don't see: "This is a fast, cookieless domain intended for static content..." then there is a chance that your anti-spam filter, firewall, router or ISP is blocking the content.

Is it just the stackoverflow coding site that's broken or do all of them look weird try, try, try?

If it's not your connection then it may be a spam filter - you could try tracert cdn.sstatic.net to see if it's timing out somewhere, or even if it can't be resolved.

  • There have not been any new changes that I am aware of. I am using the default settings on my Mac and can get the styles fine on other devices which makes me think that it's not a network firewall causing these issues. I also don't use any anti virus software because it's not necessary on a Mac computer.
    – Krejko
    Commented May 19, 2012 at 17:14
  • abcnews.go.com/blogs/technology/2012/04/… Commented May 19, 2012 at 17:21
  • Ok, I am fully aware that macs can get viruses and they are not perfect, but unless you are indicating that this virus is the cause of my SO issues, I do not see the relevance... Is that what you are trying to say? I have not had any other issues with the machine besides with the SO website which has led me to believe this is not the issue.
    – Krejko
    Commented May 19, 2012 at 17:30
  • Use developer tools in your browser to look for errors.
    – Rosinante
    Commented May 19, 2012 at 17:41
  • Great idea @Rosinate. I am mad at myself for not having thought of that and trying that earlier. I have updated the question with the errors that were found
    – Krejko
    Commented May 19, 2012 at 17:58
  • Not sure if this is a problem caused by chrome or possibly something else, but I noticed all of the failed resources have a "?36c9ba" added after the file extension. Could this be causing the issue?
    – Krejko
    Commented May 19, 2012 at 18:03
  • Fire up your browsers and paste the http://cdn.sstatic.net/careers/Img/home/intro-slogan-candidate.png?36c9ba url - you should get a large orange "upgrade your career today" message.
    – web_bod
    Commented May 19, 2012 at 18:07
  • This link works on my tablet but hangs on my Mac. The request never completes. I get a "this page can not be displayed" error
    – Krejko
    Commented May 19, 2012 at 18:09
  • I also can not get to cdn.sstatic.net or any of the other stack exchange websites. My tablet is on the same wireless network which makes me think it's not ISP blocked content, the router, or firewall. I have never changed anything with my system's local firewall and I have never before had any issues. How would I check if it's getting caught in some kind of anti-spam filter?
    – Krejko
    Commented May 19, 2012 at 18:58
  • At least we've narrowed it down a bit.
    – web_bod
    Commented May 19, 2012 at 18:59
  • I think you were right. Must have gotten caught in a filter. I did a reset of everything and it cleared it up. I would be interested in finding out what caused it to get stuck in a filter in the first pace. Thanks for the assistance. Lesson learned: sometimes when weird things start happening, all that's needed is a fresh start
    – Krejko
    Commented May 19, 2012 at 19:14
  • Good old Turn it off, wait 10 minutes and turn it back on again - it might be worth writing up the approach at some point
    – web_bod
    Commented May 19, 2012 at 19:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .