27

This is regarding the pending/suggested edit links that are seen along with questions themselves (not the ones in the edit queue which 5K+ users can see). When they read edit(0) and I approve them, they turn into edit(1) and I get a message like

Approval from one more reviewer required.

Fine. But if I instead select "Improve" for one of them, don't improve the post in any way and simply submit, the system just accepts the edit in the name of the user who suggested it, thereby bypassing the "two reviews required" stipulation.

The same doesn't happen from the edit queue which 5k+ users can access. If I choose "Improve" there and try submitting without any edits from my side, I get a message like

Error: Nothing edited. Can't submit.

Is this a bug? Are any devs looking into this?

12

This was happening for suggested edits that modified the tags of the question. We weren't correctly checking these tags when validating the edit after someone clicked improve.

This will be fixed with our next deploy. (newer than rev 2012.6.11.2879)

  • 2
    First day on the job as a dev, eh? Good luck! – Manishearth Jun 12 '12 at 3:14
  • Sorry for my ignorance @Rebecca but what does 2879 mean here? And how does that translate to the time when the deployment will be made? Are there anyways that users can come to know of the deploy history? – Pavan Manjunath Jun 12 '12 at 12:39
  • @PavanManjunath check out the footer (on the right). We list a revision number there. Every time we build, that number changes to the new revision number. – Rebecca Chernoff Jun 12 '12 at 14:51
  • 1
    the first item is time (20:12) than the date of the deploy: 6th Nov 2879, am I right? – Web Devie Jul 30 '13 at 7:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .