I have noticed that the review page is slow and takes a huge amount of time to load (if at all). I noticed this at work as well as at home. The rest of the site seems fast, its really just this one page that seems to be consistently slow.

  • Most likely a problem with your connection or computer. – caesay Jun 14 '12 at 17:40
  • 1
    So my computer has a problem with just one stack overflow page ? – Jake1164 Jun 14 '12 at 17:42
  • Or browser perhaps? That could explain the behaviour at home as well as at work... – ChristopheD Jun 14 '12 at 17:43
  • Ie8 at work, ie9 at home, two separate computers. – Jake1164 Jun 14 '12 at 17:45
up vote 16 down vote accepted

Yup, certain Review pages currently load comically slow. For example, we kindly ask that you never pay a visit to the "all" sub-tab of the "low quality" tab on Stack Overflow's review page. (You'll occasionally be greeted by a literally 2-minute page load).

We're working on overhauling the Review page entirely, which will take care of the current performance issues.

  • 6
    "we kindly ask that you never pay a visit to..." ... you realize what's going to happen, right? ;) – Bart Jun 14 '12 at 17:54
  • 7
    @Bart That's OK, they need some people to let the new moderators test out the ban button on. – Tim Stone Jun 14 '12 at 17:55
  • 1
    @TimStone /me walks away whistling innocently – Bart Jun 14 '12 at 17:56
  • 4
    Morbid curiosity engage – Ben Brocka Jun 14 '12 at 18:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .