I am a registered user of StackOverflow, and I have an OpenID from my personal domain, http://id.jdlh.com/jdlh/ associated with the account. At my domain, I delegated OpenID provision to Google. My understanding, though, is that this delegation should be invisible to StackOverflow. They see only my own OpenID.

When I attempt to log in to Stack Overflow, and supply this OpenID, I get an expected page from Google asking me to log in. Then I get the following message from StackOverflow:


This login is new to Stack Overflow:


[Confirm and create new account] [Cancel]

Neither of these is what I want to do.

How can I persuade Stack Overflow to let me log in with my personal OpenID? I don't want to create a new account with a different OpenID, and then have to merge the two.

Did I supply the wrong OpenID? No, actually; when I do account recovery, using the email address registered with my StackOverflow account, I get a recovery message which repeats the same OpenID which I used in the first place.

I checked for duplicates of this question. Some seemed similar, but aren't duplicates:

For what it's worth, here's the URL of the Confirm page. I added line breaks for legibility. The URL has a lot of query parameters which seem to indicate that my personal OpenID URL is being acknowledged. But I don't understand all those parameters very deeply:

  • Confirmed; no idea when this broke though, as I haven't tried delegating to Google for this in a while. Might be related to: meta.stackexchange.com/questions/96982/…
    – Shog9
    Jun 17, 2012 at 7:15
  • Could not reproduce with an OpenID delegated to LiveJournal; I logged out on SO and logged in, and the “my logins” popup showed that I had logged in with my personal domain rather than LJ.
    – Kevin Reid
    Jun 17, 2012 at 13:30

1 Answer 1


I am user188413, now logged in as myself, having worked around the problem.

I decided that Google didn't want to provide OpenID services properly to delegators like myself. In part I reached this conclusion from not finding any documentation where Google says it does want to provide OpenID services to delegators. In part it was based on a Stack Overflow reply where someone claims Yahoo doesn't provide OpenID services properly to delegators. If Yahoo! doesn't want to play, maybe Google doesn't either.

I created an account on the Stack Exchange OpenID provider. Then I commented out the entries in my HTML Head section which delegated to Google, and inserted the entries which delegate to https://openid.stackexchange.com/. Voila! I could log in to Stack Overflow with my own OpenID again.

I read some posts saying that the format of Google Local ID URLs changed with the advent of Google+. The old URLs used the domain name profiles.google.com, the post-Google+ URLs use plus.google.com. Simply changing the local_id link from old to new Google URL didn't fix this problem for me, though.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .