1

Is it mistake by stackoverflow or there is bug in my browser

1.

enter image description here

2.

enter image description here

6
  • 1
    What's your browser?
    – yannis
    Jun 21, 2012 at 9:01
  • mozilla firefox Jun 21, 2012 at 9:03
  • Version? And are you at the default zoom level?
    – yannis
    Jun 21, 2012 at 9:03
  • yes its on default Jun 21, 2012 at 9:05
  • 1
    It looks like you've resized your browser with the modal displayed. It seems that the image upload modal is not responsive to browser resizes. Jun 21, 2012 at 9:12
  • What are we supposed to be looking at exactly? Is it the modal dialog?
    – ChrisF Mod
    Jun 21, 2012 at 9:16

1 Answer 1

3

The "Insert an image" modal dialog appears to not be responsive when it comes to browser resizing. Here's a screenshot from Chrome:

enter image description here

The "Insert hyperlink" modal does respond to resizes though. It stays centered (both vertically and horizontally):

enter image description here

So I would guess that this is a bug with the "Insert an image" dialog.

The reason for this is the CSS applied to the image dialog:

<div style="display: block; 
            padding: 10px; 
            width: 400px;
            z-index: 1001; 
            position: absolute; 
            top: 313.5px; 
            left: 494px; " 
     class="wmd-prompt-dialog">
</div>

Compared to that of the link dialog:

<div class="wmd-prompt-dialog" 
     style="position: fixed; 
            width: 400px; 
            z-index: 1001; 
            top: 50%; 
            left: 50%; 
            display: block; 
            margin-top: -71px; 
            margin-left: -203px; ">
</div>

You can see that the link dialog is positioned with percentages, and the image dialog is positioned with pixel values, causing it to stay where it is when you resize the browser window.

Not the answer you're looking for? Browse other questions tagged .