I was just prompted to enter my name and email when answering a question on SO:

Oops! Your answer couldn't be submitted because:

name and email are missing

Then, when I tried to just post the answer again without entering data, I got this:

Little slab of meat / In a wash of clear jelly / Now I heat the pan

URL bar shows: Why is malloc really non-deterministic? (Linux/Unix)

I have been logged into SO answering questions successfully all morning.

What's up with that?

  • 4
    Related: meta.stackexchange.com/questions/32509/… – Pekka Jun 28 '12 at 19:45
  • Pretty funny :-) – Eric J. Jun 28 '12 at 19:48
  • Try logging out and back in, and clearing your cookies if that doesn't work. – Matthew Read Jun 28 '12 at 19:50
  • 5
    do you have javascript disabled, or otherwise unusual browser defaults? – Jeff Atwood Jun 28 '12 at 20:15
  • When you say "when I tried to just post the answer again without entering data", do you mean that there were input fields on the page for your name, email, and website, below the main textarea? You can see these input fields when looking at a question in incognito mode... – Jarrod Dixon Jun 28 '12 at 23:43
  • I'm just checking that you were indeed logged in, as the code that does that particular check only runs for anonymous users. – Jarrod Dixon Jun 28 '12 at 23:44

You must log in to answer this question.

Browse other questions tagged .