For the longest time, the previous edit summary was retained when editing the post again within the 5 minute grace period. It appears that now, that is no longer true, and it's extremely annoying.

Every time you edit within the grace period, it appends a new message to the edit summary unless you type something in. I really don't feel like finding my message again or re-typing it. Yet if I continue editing adding a few characters at a time, the edit message will end up looking like this:

Look at that long message...

Eventually, if you do it too many times, the system won't even let you save edits anymore without changing the edit reason. Most likely the message is now too long. Proper error message, please?

An error occurred saving the edit

If the system is forced to automatically append a new message, it should check the previous ones. I've reported a similar bug report about "edited tags" previously.

When was this change even made? If this change was intentional, I strongly encourage you to reconsider. Usually when I edit within the grace period, it's to fix small spelling or punctuation errors that I hadn't noticed when I first submitted. The edit reason I entered is still the only edit reason. If I feel I need to add to it, or I want to change it, then I will. Don't make me re-type things just to keep the edit reason from appending useless text.

  • 2
    I noticed this as well today, fully agreed with you.
    – user154510
    Jun 30, 2012 at 7:04
  • I noticed the same. When I edited the post using the "edit" link shown in the revision page, the edit summary used in the previous (still in the grace period) edit was shown.
    – apaderno
    Jun 30, 2012 at 7:26
  • 1
    it looks like developers are experimenting with ways to address "unscrupulous behavior" complaints like those in Make first draft of a new answer part of the permanent revision history
    – gnat
    Jun 30, 2012 at 11:11
  • But, @gnat, that text is not visible for edits in the first grace period?
    – Arjan
    Jun 30, 2012 at 11:23
  • @Arjan yeah weird. As I wrote it looks like they are experimenting, like what we see is some incomplete feature.
    – gnat
    Jun 30, 2012 at 11:37
  • 1
    I doubt it's related; my tests just work like the summary has always worked (including not showing any summary for the first revision, and any explicit text always overwriting the full previous comments). It's just that the summary is not pre-filled. I guess it's just a bug, @gnat.
    – Arjan
    Jun 30, 2012 at 11:39
  • @Arjan agree it's a bug (and quite painful to me as I am active in editing). I am only trying to guess what could be the reason to change system behavior that looked perfectly OK before
    – gnat
    Jun 30, 2012 at 11:44
  • 1
    This is status-completed, but what actually happened?
    – nhahtdh
    Sep 13, 2012 at 18:40
  • 1
    @nhahtdh No idea. Someone fixed it. :P I passed the link on to see if one of the devs wants to write up an explanation, but it may or may not happen depending on how busy they are.
    – Adam Lear StaffMod
    Sep 13, 2012 at 19:03


Browse other questions tagged .