7

When I hit "edit" on this question the editor shows the source not of the current revision, but the one before it.

I can reproduce this in multiple browsers, both logged in and anonymously and another user confirmed it in chat.

I found it originally via the new review queue, that much I'm certain of. I thought I'd backed out of an improve in the new review queue on this one and done it from the question page itself in the end, after it had already been approved but the timestamps in the revision history and the log on the suggested edit disagree there so I might be misremembering that.

7

This was a fun one to track down - it turned out to be a case where ordering revisions based only on creation date was somewhat of a bad idea. It only presented itself on a SQL instance with a high volume of inserts combined with a change that we made to sync up all post creation dates for an action such as improving a suggested edit which approves the existing suggested edit and inserts an additional edit all using the same exact date and time.

  • I'm not sure it is fixed. For the post discussed here, when I click the edit link on the post, I get the same "must be more substantial" notification and my edits are rejected (haven't tried a complete rewrite, perhaps that'd count as more substantial;). From the revisions page, I get the same source (rev 2) when clicking the edit link of either rev 2 or rev 3, and get a warning that I edit an old revision. – Daniel Fischer Jul 25 '12 at 18:08
  • However, anonymously suggesting an edit worked. What are the differences between the "improve this question" link for anonymous users and the edit link for logged-in users that one works but not the other? – Daniel Fischer Jul 25 '12 at 19:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .