24

On SO and Meta it will not let me start a bounty....

first bounty screenshot

(Chrome dies here, but only sometimes)


second bounty screenshot


third bounty screenshot

This last picture is where I get stuck. I press the "Start Bounty" button but nothing happens. I've tried entering a message for the user, even though it says "optional", but it still does not work. There are no Javascript errors.

Any ideas?

22
  • 1
    Do you happen to know if you're getting any errors in Chrome's developer console?
    – Zelda
    Commented Jul 30, 2012 at 16:14
  • Don't even know what that is. If you tell me how to check I will.
    – JuiCe
    Commented Jul 30, 2012 at 16:15
  • Hit F12 to open the developer tools in chrome (a big section should show up at the bottom). There's tabs at the top of the new section; click the Console one and then try and post a bounty. See if there are any new errors (in red) in the output after attempting to send the bounty. My guess is the javascript is failing
    – Zelda
    Commented Jul 30, 2012 at 16:23
  • Hmmm, not sure what happened. I pressed F12 then tried to post a bounty and the bounty just worked. Not sure what the problem is but it was solved, thanks for your time.
    – JuiCe
    Commented Jul 30, 2012 at 16:25
  • 4
    Even though this was resolved for the original author, voting to reopen as someone else seems to have the same problem, but this very question is much more detailed.
    – Arjan
    Commented Aug 12, 2012 at 17:30
  • 2
    Same issue on my end too. Win 7 firefox 14.0.1 Commented Aug 13, 2012 at 19:02
  • 2
    I'm having the same issue as well. IE9 on Win 7. I've checked the console and there's nothing.
    – mrranstrom
    Commented Aug 16, 2012 at 18:43
  • 1
    @ColeJohnson Mine actually just started working randomly. But I didn't start this bounty, this question was closed a few days ago. Someone else re-opened it and put a bounty on it.
    – JuiCe
    Commented Aug 17, 2012 at 13:26
  • 1
    I was having the same problem in Chrome & Firefox (OS X). I tried several times with no luck. I checked with VisualEvent, and jQuery was subscribed to the submit event on the form, but no code was shown for the event. About 10 minutes later I tried again, and it worked. Commented Aug 19, 2012 at 17:26
  • 2
    I am also getting this as an issue wtf.
    – Han
    Commented Aug 23, 2012 at 2:11
  • 1
    This happens randomly in FF and Chrome. Meta won't let me offer a bounty. Chrome stops on "Next" in the first popup (no JS errors), Firefox dies at Start Bounty (no js errors). It just silently fails.
    – Zelda
    Commented Aug 24, 2012 at 18:18
  • 2
    For the record it took 4 tries and two browsers to set this bounty, after another several failures at applying another bounty.
    – Zelda
    Commented Aug 24, 2012 at 18:22
  • 1
    It happened in both IE8 and Chrome, and it stopped on "Start Bounty"b both times.
    – Kobojunkie
    Commented Aug 26, 2012 at 21:02
  • 1
    Creating a bounty with Chrome 21.0.1180.81 on Ubuntu did not work for the same reason. Was able to do so with Firefox though. Commented Sep 10, 2012 at 14:22
  • 1
    @Lix I got closer and closer to 10k, which means your girlfriend would have to bake me a cake. Didn't want to do that to her just yet... (or is that not how that works?)
    – Bart
    Commented Sep 10, 2012 at 16:26

3 Answers 3

9
+100

We (read: Emmett) pushed a fix for this a few days ago, so it should be all good now.

We were missing a variable declaration that usually wasn't a problem by sheer coincidence.

If this is still broken for you and you're running the SEModifications userscript, update it to the latest version.

5
  • 3
    Any info as to what the problem was? (For no other reason than that I'm a nosy bastard)
    – Bart
    Commented Sep 14, 2012 at 19:22
  • @Bart Something something javascript something. Hold on, lemme find the chat log. :)
    – Adam Lear StaffMod
    Commented Sep 14, 2012 at 19:39
  • 2
    Haha, I will quote you on that should the question ever come up.
    – Bart
    Commented Sep 14, 2012 at 19:49
  • Nope - still happening
    – ChrisF Mod
    Commented Oct 11, 2012 at 15:51
  • (for future reference purposes)
    – Tim Stone
    Commented Oct 11, 2012 at 17:51
9
+25

Ok so I was having this issue in chrome...I tried it in IE and firefox and nothing was working. The way I got it to work was I click Start Bounty and go through the process. When I got to the third screen where everyone is having an issue with the button, I scrolled down and clicked on Start Bounty again (Leaving the first start bounty window open). You now have two bounty windows open. In the new window go through the process and then try and submit the bounty. I don't know which submit button I clicked on but one of them worked successfully

7
  • Mine already works, so if anyone else is having trouble with the problem, comment please and let us know if this is working.
    – JuiCe
    Commented Aug 24, 2012 at 19:17
  • Well as of 5 minutes ago mine wasn't working
    – Ronnie
    Commented Aug 24, 2012 at 19:17
  • I know, I just feel like there is an issue that must have a definitive answer that will explain why it keeps happening. Mine started randomly working, and the only thing that I noticed doing was pressing the F12 key. I'd like to accept an answer that has an exact answer that will help everyone, not just something that worked once.
    – JuiCe
    Commented Aug 24, 2012 at 19:26
  • I was in the F12 area and had no idea what I was looking for. I did notice that when highlighting the form tag, the submit button was not part of the highlight. It was clearly in between the form tag however
    – Ronnie
    Commented Aug 24, 2012 at 19:28
  • Same problem using FF on Win 7 - this solution worked for me.
    – Gisto
    Commented Sep 4, 2012 at 23:57
  • Same problem in Chrome 21.0.1180.89 on Ubuntu 11.10; this workaround helped. "I'd like to accept an answer that has an exact answer that will help everyone, not just something that worked once." -- I'd like the bug fixed. This is a workaround. Commented Sep 6, 2012 at 10:30
  • Not sure if you're directing that comment towards me or the devs. I am well aware that this is a workaround, but hey it's helping people start some bounties :)
    – Ronnie
    Commented Sep 6, 2012 at 16:56
1

Well, I just checked and the "Start Bounty" is ordinary submit button that is posting a form to the server with all the required information.

This means that if clicking it does not work some JavaScript code is blocking the click event.

Since there is no direct click event, most likely some jQuery code is attached at some point and on some browsers under specific conditions that still need to be reproduced, block the click event of the button.

As a workaround for those who can't start a bounty due to this problem, I suggest to disable JavaScript in their browser then the button will work just fine, being ordinary HTML submit button.
On second thought, disabling JavaScript won't work either since the bounty window itself is loaded by jQuery.

1
  • 7
    Oh the irony of placing a bounty on a question titled - "Why can't I start a bounty?"... classic :)
    – Lix
    Commented Aug 13, 2012 at 7:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .