10

I wanted to login to stackoverflow.com with my newly created Stack Exchange account. Unfortunately, it's not possible with Firefox on Mac OSX, because the four buttons on the login page below "Do you already have an account on one of these sites? Click the logo to log in with it here:" are not working. Clicking has no effect at all: not even throwing JS errors.

Maybe this could be a hint: When opening stackoverflow.com or meta.stackoverflow.com I always get the following log entry in the console:

[01:31:30.125] SecurityError: The operation is insecure. @ http://stackoverflow.com/:2879

It seems like other StackExchange sites aren't affected.

I'd really like to find a way to use Stack Overflow with Firefox.

  • What version of Firefox are you using? – Michael Petrotta Aug 9 '12 at 23:47
  • I'm using Firefox 14.0.1 – tobi_nk360 Aug 10 '12 at 13:27
  • Are you running through a proxy connection? If so... – Gaffi Aug 10 '12 at 15:56
  • Disable any add-ons or unusual plugins you have running, and try it again. This isn't normal, and you shouldn't be seeing it. – Shog9 Aug 11 '12 at 0:08
3

My guess is that cookies are not enabled. Try enabling cookies for stackoverflow.com and stackexchange.com, and try again.

  • 1
    More precisely: Manual approval of cookies for stackoverflow.com and stackexchange.com is insufficient, as they appear to be time-sensitive (i.e. you can't approve cookie requests individually via the "Ask me every time" browser preference). You have to whitelist the cookie domains so they all complete quickly, or the OpenID gymnastics won't work. – ewhac Oct 18 '13 at 19:51
  • I've been trying to figure this out for ages-- Thanks! What worked for me was going to preferences, privacy, and under history, switch to "use custom settings for history", exceptions... and I deleted the entire list of exceptions. I must have blocked cookies from somewhere important a long time ago and it never mattered until now. Oddly, this caused the "sign in with google" link to do nothing when clicked other than send a message to the console as in the original question. Very frustrating. – garrett mitchener Dec 7 '15 at 20:37
0

When using firefox, trying the Google option (" the four buttons on the login page") on
windows 7 with cookies whitelisted (disabled for all except for those on the whitelist)
I had the same problem.

A solution that sacrifices session privacy and maintains it in between browser sessions for firefox.

Enable "Accept third party cookies", this is a solution for your login problem.
Choose Keep until Firefox closes.

Use the whitelist for cookies you want to keep.

Greetings

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .