From the /import web page, accessed through "Add an application" link in the "Edit profile" page, my projects can not be imported and the error message is not clear:

  1. Go to http://careers.stackoverflow.com/import/project/65831
  2. Type https://www.civiclinks.it/en/
  3. Click "Get project"
  4. The "Sorry, we could not retrieve that URL for some reason." error message appears.

The same behaviour appears using these links:

  • Might the HEAD request be failing (meta.stackexchange.com/questions/132026/…)?
    – Bart
    Commented Aug 21, 2012 at 8:45
  • Using web-sniffer.net it appears to reply with a 200 (on HTTPS). HTTP replies with a 301/Moved permanently, but it seems correct. Commented Aug 21, 2012 at 8:50
  • These URLs redirect to https:// equivalents, perhaps you should try the 302 endpoint instead? If that does work (e.g.https://www.civiclinks.it/en/) then Careers 2.0 should be updated to follow 30x redirects properly. If that doesn't work, perhaps Careers 2.0 doesn't handle (some?) SSL sites. Commented Aug 21, 2012 at 8:54
  • @MartijnPieters All the above mentioned endpoints have been tried and noone works (i.e. HTTP and HTTPS, returning redirect and OK answers). Commented Aug 21, 2012 at 9:10
  • 1
    Well, since your SSL cert is a DigiCert issue, it looks like Careers 2.0 either cannot handle HTTPS sites at all, or doesn't handle Transfer-Encoding: chunked; I don't see anything wrong with your sites in any case. Commented Aug 21, 2012 at 9:24
  • 1
    Happened to me with importing articles a while back: meta.stackexchange.com/questions/125403/…. They managed to fix it at the time though. Could it be the same issue here?
    – Tudor
    Commented Aug 21, 2012 at 12:18
  • @Tudor behavior seems compatible with the one of your issue: it gets a while for the error message to appear. however, HTTPS returns a 200, not a redirect, so I don't know what happens under the hood on the careers website. Commented Aug 21, 2012 at 12:51
  • @Sid: I went ahead and put a bounty to get things moving. Hopefully a mod/staff will see it now and attempt a fix.
    – Tudor
    Commented Aug 23, 2012 at 15:19
  • @Tudor: Hey, thank you so much! Commented Aug 24, 2012 at 15:40

1 Answer 1


This works now, and probably has for some time. Likely related to the HEAD issue listed in the comments (we switched back to a GET).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .