2

When viewing the list of questions (or answers) in my profile, I click a question (or answer) to read. When I want to go back to the list, I navigate "back". This returns me to the first page of the list, regardless of which page I was on. However, the URL indicates that I am on the correct page, and I am unable to click that link to that page to return until I load another page ("next" works, though, so a 2-pager wouldn't be impossible).

This makes it pretty annoying to try to read posts in any logical order (votes, activity or newest).

enter image description here

I've reproduced this reliably in IE8 on SO and MSO sorting questions and answers, and EL&U with answers.

5
  • 1
    Uhoh, IE8; this works just fine in FF14, in case you wanted to know that.. Commented Aug 21, 2012 at 12:54
  • 3
    I can hardly contain my surprise
    – yoozer8
    Commented Aug 21, 2012 at 12:55
  • Note that for this to work properly in browsers, you need to use the history API, which IE8 (nor IE9) support. See caniuse.com/#search=history Commented Aug 21, 2012 at 12:56
  • Dude, you are using IE and complaining about bugs? Seriously? You are lucky enough that you are not paying taxes on SE like you would do on some other sites (telegraph.co.uk/technology/microsoft/9331808/…). Try using a real web browser. You will see the world wide web from a different angle. Personally, the only scenario when IE is useful to me and when I actually use it is when I reinstall Windows, I use it to download a web browser for my OS. Commented Aug 21, 2012 at 22:42
  • 5
    Whoa, deep breath, @DarinDimitrov. Some people work on super-locked-down corporate machines.
    – Pops
    Commented Aug 22, 2012 at 14:26

0

You must log in to answer this question.

Browse other questions tagged .