I'm not able to answer a question on Stack Overflow because the Human Verification page is showing up but without any CAPTCHA. I found many questions relating this but without a solution that worked for me. I guess this has something to do with my No-Script settings (Firefox plug-in). I selected "Temporarily allow all this page" several times but without success. I don't know of any proxy related restrictions on my internet connection but anyhow I there were some, I couldn't change them. Does this mean I can't pass the "Human verification"?

Human Verification - Are you a human being?

Chrome console with XHR time out

  • Can you post screenshot of what you see? Can you temporarily disable the plugin or try from different browser? – Shadow Aug 27 '12 at 13:59
  • The same in here, usually it works (the big checkbox is loaded), but now I've refreshed and re-tried few times and no luck. Could be just my connection or something. – kenorb Sep 30 '15 at 16:24
  • I just had the same problem without No-Script plugin, using Safari with only AdBlock but it's disabled on SE and should block Google's ReCaptcha either way. – zakinster Jan 22 '18 at 16:08

I don't know exactly how NoScript works, but there might be some setting for blocking/allowing third-party scripts. The reCAPTCHA script gets loaded from http://www.google.com/recaptcha/....

Also, if you disable JavaScript altogether (in Firefox, not NoScript), the <noscript> version of the Captcha page should get displayed, which doesn't require JavaScript at all.

  • In the beginning, I tried it with Java Script completely disabled. Then, I also allowed all from google.com. – ulmo Aug 27 '12 at 13:28
  • Did you disable JavaScript in NoScript or in Firefox itself? I think it makes a difference. Also, try visiting google.com/recaptcha/api/…. If you can't see the image there either, your problem isn't related to JavaScript. – Dennis Aug 27 '12 at 13:32
  • JavaScript is enabled in Firefox settings. The CAPTCHA on google.com/recaptcha/api/… shows up. – ulmo Aug 27 '12 at 13:35
  • Then try disabling it in Firefox. That should display the <noscript> version. – Dennis Aug 27 '12 at 13:36
  • Disabling NoScript and disabling JavaScript in Firefox settings worked. A related but different problem is that without JavaScript, I can't comment. ;) Thank you! – ulmo Aug 27 '12 at 13:43
  • Well, in any case, this is a workaround. With NoScript disabled and JavaScript enabled, it should work. – Dennis Aug 27 '12 at 13:45
  • 1
    Yes, and it also works with disabled JavaScript. But I consider the fact that my browser behaves different with JavaScript disabled via Firefox settings compared to JavaScript disabled via NoScript as a bug (or at least unexpected behavior) of NoScript and not Stack Overflow. – ulmo Aug 27 '12 at 13:54
  • But in China we don't have Google. So how can I solve this problem – ZhaoGang Nov 2 '18 at 11:49

I had this same issue in Firefox. It was casued by having tracking protection turned on. I was able to fix it by going to "Preferences" and then to "Privacy and Security" And temporarily disabling "Tracking Protection"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .