19

I can only reproduce this at EL&U because I don't have 10K elsewhere. It could be a problem elsewhere.

Yesterday a deleted answer had a little note saying who deleted it and when:

answer with deleter info

Today that same answer does not have that information:

answer without deleter info

Link to the particular answer

This is happening on both meta and main EL&U.

Should I be able to see who deleted something and when?

18
  • I see this on SO as well (example question). Possibly by design? Sep 5 '12 at 11:17
  • 4
    Yes, since you have over 10K you should be able to see who deleted something and when. Smells like a bug.
    – yannis
    Sep 5 '12 at 11:17
  • @MartijnPieters Hm? Your example was voluntarily removed by its author.
    – yannis
    Sep 5 '12 at 11:17
  • Good to know, @YannisRizos. I thought I was losing it!
    – Meta Ellen
    Sep 5 '12 at 11:18
  • @YannisRizos: But I don't see the reason listed anymore. If you do, then that's another datapoint. Sep 5 '12 at 11:19
  • @MartijnPieters I don't see the deleted question (need to get 9163 moar rep for that, brb), but I see it listed as "This question was voluntarily removed by its author." in the 404 page.
    – yannis
    Sep 5 '12 at 11:21
  • @YannisRizos: Right, but I, as a 10K user, don't see a reason listed. A deleted answer on the other hand does have the reason listed. Sep 5 '12 at 11:23
  • 1
    Confirmed here on meta as well: meta.stackexchange.com/a/145978/152859 screenshot Sep 5 '12 at 11:24
  • Interesting, so we can find answers (deleted over a day ago) that do have the reason included, and answers where the reason has gone. Sep 5 '12 at 11:28
  • @ShaWizDowArd It's revision history shows it's a self delete. The information is there, just not displayed properly?
    – yannis
    Sep 5 '12 at 11:38
  • 2
    I see the same behaviour on Super User as well. Posts deleted by me/other mods don't seem to be showing who deleted it Sep 5 '12 at 11:39
  • @Yannis indeed, looks like design glitch not data problem. Sep 5 '12 at 11:40
  • 2
    I confirm on Ask Ubuntu.
    – jokerdino
    Sep 5 '12 at 11:46
  • I started to notice this last night. On one occasion, refreshing the page filled in the delete info, but not in others. Very strange. Here is an SO example from 5 seconds ago showing that it is not happening in that instance.
    – tchrist
    Sep 5 '12 at 14:29
  • 1
    I can confirm this behavior. As moderator on Drupal Answers, I see who deleted a question, but not an answer. This is pretty not consistent. Why could I see who deleted a question, but not an answer?
    – apaderno
    Sep 5 '12 at 14:47
8

This will be fixed in the next deploy.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .