For the past couple days, I'm being forced through the captcha for every answer I give here on Meta and SO.

This sort of problem was brought up on Meta in the past couple months (I am not a robot!), but 1) was only in the context of making quick edits (which haven't been a problem for me) and 2) was supposed to have been fixed. I'm seeing the captcha every time I post an answer without any sort of activity that might involve rate-limiting.

What's going on?

Potential causes that don't appear to be the problem:

  • Answering too quickly and hitting rate limits.
    When posting test answers that I purposely spend multiple minutes composing, I still get the captcha.
  • Captcha based on my shared IP.
    An answer posted from an alternate account went through with no problem.
  • Are you within a company/school/university network? Might others be using SO from within the same network? Commented Oct 4, 2012 at 21:13
  • @DavidThomas I am on a shared connection at the office, but nothing's changed in that regard. While possible that someone else here has started doing something to trip the limits, I have no reason to suspect that's the case. Moreover, I thought that one of the purposes of having an account instead of anonymous use was more fine-grained limiting in the case of shared connections.
    – blahdiblah
    Commented Oct 4, 2012 at 21:19
  • If you take too long or too short to post a message (e.g. copy paste/leave the PC for a while then come back and post) it seems to captcha you every time
    – Zelda
    Commented Oct 4, 2012 at 21:27
  • @BenBrocka I just tried posting answers to the sandbox, purposely spending a full minute composing one and two minutes on the second, and still got the captcha. Is the lower cutoff higher than that?
    – blahdiblah
    Commented Oct 4, 2012 at 21:31
  • @blahdiblah that should be good. I'm wondering if David's right about it suspecting your IP for some reason
    – Zelda
    Commented Oct 4, 2012 at 21:34

1 Answer 1


After seeing this answer from Jeff, I realized that the shiny new userscripts I installed recently might have something to do with the problem. Testing revealed that the WMD keyboard shortcut disabler was the culprit.

Time to work on getting the same functionality without forcing me to constantly prove my humanity.

An updated Chrome user script based on Rob's (linked above):

// ==UserScript==
// @name           Cya WMD shortcuts
// @namespace      Rob W
// @version        1.0
// @run-at         document-end
// @description   A hook to disable WMD keyboard shortcuts
// @match       http://stackoverflow.com/*
// @match       http://meta.stackoverflow.com/*
// @match       http://superuser.com/*
// @match       http://meta.superuser.com/*
// @match       http://serverfault.com/*
// @match       http://meta.serverfault.com/*
// @match       http://askubuntu.com/*
// @match       http://meta.askubuntu.com/*
// @match       http://answers.onstartups.com/*
// @match       http://meta.answers.onstartups.com/*
// @match       http://stackapps.com/*
// @match       http://*.stackexchange.com/*
// @exclude       http://chat.stackexchange.com/*
// @exclude       http://chat.*.stackexchange.com/*
// @exclude       http://api.*.stackexchange.com/*
// @exclude       http://data.stackexchange.com/*
// @exclude       http://*/reputation
// ==/UserScript==

(function() {
    var p = document.getElementById('wmd-input').parentNode;
    function ignore(e){e.metaKey && e.stopPropagation();}    
    p.addEventListener('keydown', ignore, true);
    p.addEventListener('keypress', ignore, true);
    p.addEventListener('keyup', ignore, true);

Rather than eating all keyboard events, this only prevent Markdown from seeing command+whatever events.

  • Better yet would be to install the event handler on document and check e.target. Commented Mar 16, 2022 at 20:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .