Multiple bugs on SE sites for IE10 on Windows 8:

  • Unable to upvote or downvote enter image description here
  • Unable to edit a question enter image description here
  • Asking a question without a title generates a validation error: title required. After entering a title, validation error remains.

Is there a timeline to fix these? The first two bugs are killer.

This is the response body I got while trying to edit a post:

    <script type="text/javascript">
        _qevents.push({ qacct: "p-c1rF4kxgLUzNc" });

  • Sounds like JavaScript is blocked for some reason. Can you check JS console? – Shadow The Princess Wizard Oct 23 '12 at 13:56
  • 4
    Anyway, IE10 is still not supported - so this isn't a bug just yet. – Shadow The Princess Wizard Oct 23 '12 at 13:57
  • 3
    IE10 is the current release of IE on the current platform. Win8 has reached RTM. The wikipedia page referenced on that question only lists the release previews of Win8. – Nathan DeWitt Oct 23 '12 at 14:06
  • I won't argue on that, but until that linked post will be updated it means Stack Exchange sites are not officially supporting IE10 that's all. – Shadow The Princess Wizard Oct 23 '12 at 14:09
  • I don't see any errors in the JS console. JavaScript is enabled and seems to be working fine. – Nathan DeWitt Oct 23 '12 at 14:11
  • 3
    @ShaWizDowArd, update the linked page then. It doesn't appear (based on the edit history) that Stackexchange employees update it as, and I quote, it is "the community's best guess".... Note that the answer from Jeff states that "We support current and previous versions" and "formally released browsers are supported". On that basis I'd suggest Internet Explorer 10 is supported. There is nothing official about a list which is given with the caveat "the community's best guess" =) (All that said, SO was working for me last night on IE10!) – Rob Oct 23 '12 at 14:13
  • I have made the proper updates. These can now be considered bugs. – Nathan DeWitt Oct 23 '12 at 14:25
  • OK fair enough Nathan and @Rob. Still, can you check the JavaScript console to see if it contains any clues? – Shadow The Princess Wizard Oct 23 '12 at 14:29
  • @NathanDeWitt - IE10 is not the current release, it's released to manufacturing, that's not the same as "released"...that's "released with restrictions". There are more bug fixes to IE coming before general availability. – Nick Craver Oct 23 '12 at 14:31
  • @ShaWizDowArd, I mentioned earlier. No errors in the script console. – Nathan DeWitt Oct 23 '12 at 14:32
  • 2
    @Nick I did a research and everything I found said that RTM is the same as final release. :/ – Shadow The Princess Wizard Oct 23 '12 at 14:41
  • I can't reproduce any of this behavior with IE10 on Windows 8 RTM. – BoltClock's a Unicorn Oct 23 '12 at 14:49
  • @BoltClock'saUnicorn - I don't know what to tell you. I included screenshots. This is Win8 RTM as well. – Nathan DeWitt Oct 23 '12 at 14:51
  • 2
    @ShaWizDowArd: Like he said, RTM is only available for OEMs and specific groups of consumers, but not to the general public. There is no technical difference, but there is a marketing difference, so to speak. But we all know that Windows 8 is landing in just 3 days anyway, so... – BoltClock's a Unicorn Oct 23 '12 at 14:51
  • 1
    Errors happen all the time. First noticed the errors and asked about it 7 months ago. – Nathan DeWitt Oct 23 '12 at 15:04

I have Win 8 installed as my main machine and I'm not having any issues with our sites on IE 10.0.9200.16384.

Are there any files not being sent to your browser (e.g. http status 404)? You can check this from the F12 developer tools -> Network tab -> Start capturing button.

When you try to do any asynchronous operations, e.g. voting, inline editing, what does that Network tab show? Are the requests failing? Are there any errors in the Console tab?

On these asynchronous operations, we're seeing you receive 500 server errors on each one, specifically the ones that have our CSRF prevention mechanisms in place. This leads me to think you're not sending your fkey form value on your ajax POST requests.

Thanks for helping us debug this.

  • So how exactly do I send my fkey form value on my ajax POST requests? – Nathan DeWitt Oct 23 '12 at 20:11
  • There were no errors, and yes I am receiving 500 server errors, and the response body I receive is at the end of my question. – Nathan DeWitt Oct 23 '12 at 20:12
  • See if your fkey is being set; just type StackExchange.options.user.fkey into your Console tab. – Jarrod Dixon Oct 23 '12 at 20:55
  • >> StackExchange.options.user.fkey "'StackExchange' is undefined" – Nathan DeWitt Oct 24 '12 at 5:43
  • opened a new window, tried again: StackExchange.options.user.fkey: "f7bdd3972cecb8c5d67682d506b67085" but I still can't upvote. – Nathan DeWitt Oct 24 '12 at 6:13
  • Can you try reproducing the behavior in IE's InPrivate Browsing mode? – Jarrod Dixon Oct 24 '12 at 23:20
  • It is reproducible in IE InPrivate mode. Click Vote Up, get an error has occurred box, StackExchange.options.user.fkey has a value set. – Nathan DeWitt Oct 25 '12 at 14:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .