11

I use the RequestPolicy plugin for FireFox and noticed that the global inbox/notifications currently doesn't work (at least not here in Germany): It shows the new message indication, but the popup does not show. The reason seems to be some broken DNS: SX asks for access to the IP 69.59.197.29. If I enable access to that IP with RequestPolicy, the inbox works.

  • 3
    This just started happening? E.g. could be an artifact of the fail over to the Oregon DC? – Tim Post Oct 30 '12 at 7:55
  • @TimPost♦: It worked yesterday evening in Germany, so 10h before. – Martin Schröder Oct 30 '12 at 7:57
  • 1
    This IP is used for the web sockets connection, the actual request URL is ws://69.59.197.29/ however the notifications take data from different place. Weird.. – Shadow The Dragon Wizard Oct 30 '12 at 8:09
  • 1
    Saw this too, the proxy here appears to choke on websockets, so I had an exception in for the sockets.ny.stackexchange.com url. Now it's hitting this IP directly, for some reason. – Benjol Oct 30 '12 at 8:27
  • Just tried this, and had the same issue. Added an exception for the IP address, then it worked just fine. – Nightfirecat Oct 30 '12 at 8:44
  • @Nightfirecat: Yeah, but it shouldn't use the IP, but some name. – Martin Schröder Oct 30 '12 at 8:45
  • @MartinSchröder: I agree. Just noting that the issue isn't local to you - I'd guess that anyone using RequestPolicy will have the same problem. – Nightfirecat Oct 30 '12 at 8:49
  • 2
    According to the whois that IP belongs to a company in Oregon. This might be a fast-fired-solution due to Sandy hitting NY. Joel said earlier that they'd switch all services from NY to OR. – Time Traveling Bobby Oct 30 '12 at 10:54
  • @SulfurizedDemonbobby this is clearly a Firefox issue, as it's tied to one of its plugins. Why did you remove the tag? – Shadow The Dragon Wizard Oct 30 '12 at 11:24
  • @ShaWizDowArd: This is not caused by the plugin. – Martin Schröder Oct 30 '12 at 11:38
  • You mean that it always fail, also with other browsers? – Shadow The Dragon Wizard Oct 30 '12 at 11:43
  • 2
    @ShaWizDowArd: I picked it up as "Inbox stopped working because my Plugin is blocking all direct IP requests...why is the Inbox directly querying an IP instead of a name?" – Time Traveling Bobby Oct 30 '12 at 12:15
  • @ShaWizDowArd: Most likely. I can only test with FF: Firebug shows access to that IP. – Martin Schröder Oct 30 '12 at 12:24
  • 3
    Yep, unrelated to firefox -- the plugin part just makes it obvious that the website is sending requests directly to an IP address. Same thing happened to me, and I found this post via searching for the IP address. (69.59.197.29) – Yakk Oct 31 '12 at 1:14
  • Saw the same thing. (I love RequestPolicy.) It never occurred to me it might be something to do with a hurricane. – TRiG is Timothy Richard Green Nov 1 '12 at 15:21
7

This is a temporary solution for websockets as part of the Oregon failover due to the hurricane that hit NYC.

We'll eventually start routing by a proper domain again, either when we return to our NY data center or after we've finished settling into Oregon.

  • Why are you using the IP for sockets.ny.stackexchange.com instead of the name? – Martin Schröder Nov 1 '12 at 22:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .