2

This post suggests data.stackexchange.com endpoint to connect using OData from Linqpad.

https://data.stackexchange.com/stackoverflow/atom gives Server Error in '/' Application.. This seems security flaw, A nice Error Page (like that comes in Stackoverflow.com) would be great, but that is another issue.

In the linqpad, error message is "500 Internal Server Error".

My question is What is the correct URL to connect through OData protocol?

5
  • 2
    How is an error page a security flaw?
    – balpha StaffMod
    Commented Jan 11, 2013 at 11:12
  • OK, it is not flaw.Appropriate Settings are configured (and stacktrace is visible only to local server machines and NOT to remote machines).But Custom error page like this is better.
    – Tilak
    Commented Jan 11, 2013 at 15:33
  • 1
    Yeah, I agree it's not pretty; it's just not a security issue. And even a stack trace wouldn't be; after all the data explorer is open source.
    – balpha StaffMod
    Commented Jan 11, 2013 at 17:26
  • 1
    can you tell me the reason why its not working, is it down, or there is some other URL?
    – Tilak
    Commented Jan 11, 2013 at 17:39
  • I don't know, the data explorer isn't exactly my area of expertise.
    – balpha StaffMod
    Commented Jan 11, 2013 at 17:40

1 Answer 1

4

When fixing the odata.stackexchange.com to data.stackexchange.com redirect issue (they're the same site in IIS) it broke the odata bindings because the service model (by default) is unhappy with multiple bindings per site on the same protocol.

I've made the appropriate adjustments and it's back up and running.

6
  • Yes, not it is working. It may be wrong to ask, but can you elaborate the underlying issue that caused "multiple bindings per site on same protocol" to fail
    – Tilak
    Commented Jan 12, 2013 at 13:00
  • @Tilak - yeah sure, here's the relevant article: msdn.microsoft.com/en-us/library/ee358763.aspx Commented Jan 12, 2013 at 13:50
  • This still does not work for me. I am getting a 404-Not Found error. I am using Linqpad in this case.
    – user237367
    Commented Oct 20, 2013 at 20:04
  • still has a 404 - Not Found error
    – John Babb
    Commented Dec 7, 2014 at 12:24
  • @JohnBabb it redirects fine here - what IP are you seeing for that address? Commented Dec 7, 2014 at 13:23
  • @NickCraver if I ping the address: Pinging data.stackexchange.com [69.59.197.23] with 32 bytes of data: Reply from 69.59.197.23: bytes=32 time=97ms TTL=48
    – John Babb
    Commented Dec 8, 2014 at 10:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .