When I attempt to click the mod link from within the review tools using Safari 6 on OS X 10.8, the red bordered mod frame is clipped and no tools are visible.

No extensions, standard browser - pretty much an out of the box 10.8.2 system. Safari is v 6.0 (8536.25) but I've seen this for some time, but just not gotten around to asking about it until now. The same rendering artifact exists on mobile safari iOS 6.0.2.

I'm referring to the mod link that shows up on the right under the controls - close to where the end of the big orange arrow points.

Mod link is clipped as shown here

It's clear from the two answers we have that this error is not a site-wide issue, but does affect moderators on at least one site - Ask Different.

With the recent code changes to review being rolled out I wanted to show how this glitch affects the changed code. Clicking the mod link now brings up a almost entirely white covering of the tools the orange arrow indicates:

enter image description here

enter image description here


I tried with Safari 6.0.2 (8536.26.17), and it works fine for me, on Drupal Answers: When I click on the "mod" link shown for a post to review, this is what I see.


I also tried with a different review queue, but I don't see any difference.


If that makes any difference, the revision shown on that site is 2013.1.11.910, and I am using OS X 10.8.2 (Build 12C60).

  • Thanks for checking and documenting it working. I wonder if there's anything else I might clear or why this has been broken for me for a while now... Do you install flash player or any extensions into Safari? Maybe I need to get a plug in or two?
    – bmike
    Jan 13 '13 at 15:59
  • Are you the only moderator on Ask Different with this problem?
    – apaderno
    Jan 13 '13 at 16:11
  • I have the Flash player, but that should not make any difference, as the dialog box is normal HTML written by JavaScript code.
    – apaderno
    Jan 13 '13 at 16:33
  • I believe most of the others use Chrome almost exclusively - I'll ask them to all check and send them this link.
    – bmike
    Jan 13 '13 at 16:46
  • It looks like Kyle Cronin was able to determine the exact code (the sidebar div has position: relative) that shows on the sites with this bug as opposed to those without this bug (meta and yours for instance).
    – bmike
    Jan 14 '13 at 0:23

I can reproduce this. It seems to be caused by the following CSS rule:

#sidebar, .sidebar {
    overflow: hidden;

It should probably be overflow: visible.

edit: Looking into this further, it seems that on Ask Different the sidebar div has position: relative and the mod box is positioned relative to that, whereas on Meta the sidebar div does not have position: relative and the mod box is absolutely positioned on the page.

  • This seems to fix the issue with no repercussions on the user end. I wonder if the developers have a problem with implementing this change?
    – bmike
    Jan 26 '13 at 16:19
  • 1
    The relative thing seems to be the culprit here. Thanks for digging!
    – Shog9
    Jan 27 '13 at 0:47
  • Is this still the same issue with the change that was made to review? Thinks look differently, but are still "broken" for using the mod tools from a review item.
    – bmike
    Feb 8 '13 at 15:55

Since this does not affect all sites, I'll raise the issue on our site's meta and work on getting it resolved there.

Moderator tools from the review pane are broken in Safari and Chrome

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .