I can login fine using IE and FF, but with Opera when I get redirected back from the Google login page, I'm still not logged in. I looked through the tips at I Cant Log In With My OpenID Troubleshooting Tips but they don't apply or seem to have no effect on my setup (which is quite vanilla, actually). I'm using Opera 9.64 on Vista... any further troubleshooting tips?

Edit: The Vista system is a work computer. At home I run Opera 9.63 (almost same version) on Ubuntu 9.04, and this issue does not occur. I'm pretty sure my home system has similar preference settings (cookies etc). I also have a VirtualBox setup with a Windows 2000 system, with Opera 9.62 on that also (can you tell I like Opera?) and that setup also works. I upgraded both of these to 9.64 and I can still log in without issue.

  • 1
    I've seen some crazy things happen with Opera when running Stack Overflow locally - an error page will come up concerning the redirect back from my OpenID provider to my machine. I just hit F5 (refresh) and it then loads the url. This is the only browser I've seen with a redirect during authentication problem. Commented Aug 22, 2009 at 8:11

2 Answers 2


First, make sure you have cookies enabled/accepted.

Then, Ctrl + F12 (menu Tools -> Preferences) and go to

Advanced > Network

Uncheck Enable automatic redirection.

Then go through and login with your OpenID.

See if that works.

Possible reason why this fix works

Maybe it has something to do with Opera not liking the various redirects happening "behind the scenes". When you manually click through each of the redirect pages, it's reminding Opera to stay on session and to not drop the cookies when moving between Stack Overflow and your OpenID provider.

  • This does work, which sorta raises more questions - why would automatic redirection cause it to fail? And I tried out Opera on my home system (see edit to question) and it works without turning off automatic redirection. With it turned off, I now have to click through one Opera warning "page", and then two "object moved here"-type pages. Anyway, I can put a button to toggle on/off the automatic redirection up on the Opera toolbar, which isn't quite a perfect workaround but I think I'll survive :) Thanks!
    – weiji
    Commented Aug 22, 2009 at 7:35
  • (insert snarky comment about Opera here.) but thank you, this will be very helpful to other Opera users. Commented Aug 22, 2009 at 8:07
  • The 2.4% audience has to look out for each other.
    – random
    Commented Aug 22, 2009 at 8:14

Can you run Opera in "safe mode" and disable all customizations / preference overrides?

I've seen this before with users who manipulate their cookie settings in Opera to non-default values.

  • 1
    Actually, I'm not sure if there is a safe mode at all for Opera... Google didn't turn up anything for it and I can't recall ever hearing about it (I've been using it since version 5). Anyway, my cookie settings aren't too exotic (in fact, I don't think I bother messing with them much anymore so they might be the defaults when I installed it) and in light of my further investigation (see question edit) I don't think it's the cookie settings. But thanks!
    – weiji
    Commented Aug 22, 2009 at 7:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .