7

See:

enter image description here

The broken image links to:

http://stackexchange.com/users/flair/218674.png which redirects you to http://stackexchange.com/error?aspxerrorpath=/users/flair/218674.png

Here is the header information:

enter image description here

and a curl request:

Nathans-iMac:~ nathan$ curl http://stackexchange.com/users/flair/218674.png
<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a href="/error?aspxerrorpath=/users/flair/218674.png">here</a>.</h2>
</body></html>
Nathans-iMac:~ nathan$

Update

Both me and @MartijnPieters have tried from various locations and it seems to be a hit and miss thing. From my location I get redirected, but from my personal VM the image downloads correctly.

  • 2
    No repro – hims056 Jan 23 '13 at 12:48
  • @hims056 That's strange. Does stackexchange.com/users/flair/218674.png load correctly? – Prisoner Jan 23 '13 at 12:49
  • Yes I can see it! – hims056 Jan 23 '13 at 12:50
  • if I load it through https it loads correctly, otherwise redirects me to the 404 – Prisoner Jan 23 '13 at 12:52
  • 1
    Loads correctly for me; the /error?aspxerrorpath= entry there points to a temporary failure. Try a force reload / cache clear. – Martijn Pieters Jan 23 '13 at 13:12
  • cleared my cache, tried in a browser that I haven't used in ages. Strange problem.. – Prisoner Jan 23 '13 at 13:43
  • @Prisoner: have you tried using the incognito (private) browser mode (Chrome or Firefox) to look at that URL while not logged in? – Martijn Pieters Jan 23 '13 at 13:55
  • @MartijnPieters I tried with the incognito mode in Google Chrome, but that flair link gives me an error message (the one with the panda). – kiamlaluno Jan 23 '13 at 13:59
  • @kiamlaluno: Nope, still works fine for me, incognito or otherwise, with or without a cache clean. IP address for stackexchange.com is 69.59.197.21 according to my DNS. Perhaps yours is different and we are looking at different servers? – Martijn Pieters Jan 23 '13 at 14:03
  • @MartijnPieters That is the same IP I get from pinging stackexchange.com. – kiamlaluno Jan 23 '13 at 14:05
  • same IP for me as well when pinging SE.. – Prisoner Jan 23 '13 at 14:07
  • Tested with wget http://stackexchange.com/users/flair/218674.png as well, works too. Ah, but on my home server this fails! Suddenly, the customer network here is suspicious... – Martijn Pieters Jan 23 '13 at 14:09
  • @MartijnPieters pastebin.com/PEwhiQCG thats what I get – Prisoner Jan 23 '13 at 14:10
  • Yet on the 3G network on my phone it works. Yay for either network-wide caches or intermittent failures! – Martijn Pieters Jan 23 '13 at 14:24
  • More data points: different servers located in different networks either consistently get the error, or consistently load the image. – Martijn Pieters Jan 23 '13 at 15:45

You must log in to answer this question.

Browse other questions tagged .