2

These two features stopped working for me since a couple of days. I have to refresh the browser every now and then to see newly posted questions/answers.

is it only me ? or is anyone else experiencing the same problem?

EDIT : after trying the link @ShaWizDowArd gave me, these are the disconnected parts :

enter image description here

enter image description here

enter image description here

I'm not good with sockets so I wouldn't know what they mean :)

13
  • on which page ? stackoverflow.com/questions ?? Feb 4, 2013 at 13:15
  • @NullPointer yes in stackoverflow and I search for a certain tag like C# for example Feb 4, 2013 at 13:17
  • @NullPointer It doesn't work in meta as well Feb 4, 2013 at 13:19
  • looks fine to me i.stack.imgur.com/Uybxe.png Feb 4, 2013 at 13:23
  • Did you change browser by any chance? When you browse to this test page, what you see? Also, you might have installed new anti virus that is blocking web sockets.. Feb 4, 2013 at 13:26
  • @NullPointer thats weird. is it something to do with connection speed? Feb 4, 2013 at 13:27
  • @AbZy speed isn't relevant it's using web sockets connection with the server. Kind of "live AJAX". Feb 4, 2013 at 13:28
  • @ShaWizDowArd websockets 80 and 8080 not connected. everything else is fine Feb 4, 2013 at 13:28
  • @AbZy so that's your answer. What browser? What anti virus you have? Feb 4, 2013 at 13:28
  • @ShaWizDowArd I've always been using Firefox and it used to work. I haven't installed any new anti-viurs. been using windows security essentials Feb 4, 2013 at 13:30
  • Well, nothing to do with Stack Overflow then, see this answer. Try using Chrome, hopefully its web sockets are still working. Feb 4, 2013 at 13:39
  • @ShaWizDowArd I downloaded Chrome and it worked. could you please edit your answer so I could mark it as accepted? Feb 4, 2013 at 14:47
  • Done, though it's still bit strange what caused Firefox to stop liking web sockets. :/ Feb 4, 2013 at 15:01

1 Answer 1

2

You probably switched to different tab by mistake.

The live updates are present only in the active tab, e.g. active tab for C# tag.

As it currently stands, the site "remembers" your last tab so once going to other tab, any time you visit a tag page it will go to that tab.

Turned out that your browser stopped supporting web sockets as proved in the test page.

Lots of things can cause such a thing (anti virus, corrupted browser update, incorrect proxy) none of those can be controlled or fixed by Stack Exchange.

Looks like that to this day, Chrome is the most reliable browser where it comes to supporting web sockets so to enjoy the full experience of live updates, it's better to use that browser.

7
  • I'm always on the Newest tab. and the problem still persists. Feb 4, 2013 at 13:22
  • and how do you explain the new answers not showing ? Feb 4, 2013 at 13:23
  • As far as I know, only "active" tab has the live updates. You probably used to be in that tab and moved to "newest" tab only recently. Feb 4, 2013 at 13:24
  • I'm also wondering why firefox websockets stopped working all of a sudden even though I followed what was suggested here and found that network.websocket.enabled is already set to true. anyway thanks for your help :-) Feb 4, 2013 at 15:18
  • @ShaWizDowArd i am facing the same problem. i use chrome and on ubuntu. I tried the link you posted. it says websockets works for you. No http proxy. What do i do in this case?
    – user215192
    Jun 5, 2013 at 11:48
  • @Raghunandan web sockets do not work today, it's fault on Stack Exchange side this time and already reported. Jun 5, 2013 at 11:54
  • @ShaWizDowArd thank you for the info. I do see the newest tab. but i don't get the updates like 1 new activity.
    – user215192
    Jun 5, 2013 at 11:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .