In https://robotics.stackexchange.com/questions my question (Which is easier/cheaper: Hbridge vs ESC for controlling a motor?) contains a "$" in a quoted section of the question. Originally I had a second "$" in a second quoted section of the same question.

However when I did this the second $ seemed to trigger a style that made the text italic and lost spacing between words. I took out the second "$" and instead emphasized it with the word "dollars" which solved the immediate problem.

However, in the listing of the question, (not the question itself) the same thing happens after the first "$". The summary shows the text without spaces between words and in italic.

Seems like a bug.

Below is a verbatim copy/paste of the original issue (two dollar signs):

I was able to find a small ESC for about $12 off of ebay. If you were designing a robot, would you see that and think?

$12 bucks for an ESC that connects to simple pulse-wave interface - sign me up!

Or would you think:

$12 just to control a motor? I could throw together an H-bridge for $0.50 and be done with it.

My robot in particular actually has two motors and therefor $24 to control the two of them. But the interface is really easy (plus has the added advantage of being R/C vs computer controlled with a simple change of connectors.

Which way would you go?

  • 7
    Money always corrupts everything </obligatorySnark> ;) – Andrew Barber Feb 26 '13 at 3:05
  • 5
    Money corrupts. Absolute money, um... no, wait. – jscs Feb 26 '13 at 3:05
  • @JoshCaswell D'oh! Beat you by TWO seconds! – Andrew Barber Feb 26 '13 at 3:06
  • You guys are definitely fast! – ChronoFish Feb 26 '13 at 3:06
  • 1
    That's the second time I've had that happen today, @Andrew! – jscs Feb 26 '13 at 3:07
  • Addressing the actual question for a second, could you reproduce, inside a code block, the original text that caused the strange formatting, along with the new text? Kind of like I did in this answer. – jscs Feb 26 '13 at 3:09
  • It looks like MathJax is being triggered because the line breaks don't appear in the question excerpt, which is probably problematic. – waiwai933 Feb 26 '13 at 3:10
  • It looks like this is "by design" but in the throws of understanding the issue we uncovered another bug. Does this need to asked in form of a new question? See discussion in answer from @hayden – ChronoFish Feb 28 '13 at 0:32
  • throes, @ChronoFish. – TRiG May 8 '14 at 11:05

You're seeing latex, it allows you to write math equations in your questions and answers.
(though this is not enabled on all sites, and in particular not on meta!)

For example, writing $x^2$ will display (prettily) x squared (with the 2 super script).

You can write an ordinary $ sign by writing \$ (backslash dollar).

Note: the math site also uses this, see this post on how to use it.

  • I'll check this out...hang on – ChronoFish Feb 26 '13 at 3:14
  • Okay - that"worked" but introduced a new bug. The first $ works fine. When viewing the question, the 2nd works fine. Although there is enough of a delay that I can see the \$12 get over-written. In the question list however, the first $12 is fine and the second holds the escape ("\") – ChronoFish Feb 26 '13 at 3:17
  • @ChronoFish it takes a small amount of time to render it, so I think that is "normal" :) – hayd Feb 26 '13 at 3:21
  • I don't have a problem with it... just noting that is what I see. – ChronoFish Feb 26 '13 at 3:22
  • However, that doesn't excuse the "\$12" I'm seeing in the list of questions. The second $ is causing issues, not in the question itself, but in the list of questions. – ChronoFish Feb 26 '13 at 3:24
  • @ChronoFish That is indeed strange, that bit could be a bug? – hayd Feb 26 '13 at 3:29
  • So does this need to be opened up as a new question in order to be treated as a "bug"? – ChronoFish Feb 28 '13 at 0:33
  • @ChronoFish I think the so, since your question asked what was going with the dollar-sign, rather than the specific second dollar display issue (which you found after) :) – hayd Feb 28 '13 at 0:57
  • New bug question: meta.stackexchange.com/questions/169422/… – ChronoFish Feb 28 '13 at 1:40

Not the answer you're looking for? Browse other questions tagged .