11

In the Stack Exchange Data Explorer, the icon color for the various sites seems* incorrect: Whenever I select a main site, the icon is greyed out, and when ever I select the corresponding meta site, the icon is colored.

My initial instinct was to think that the colors of the main/meta sites following the "Switch sites:" prompt should be switched. (Actually, it seems like it's just a UI thing. See the edit below.)


*Edit: Actually, the colors are technically not incorrect, since (as Jeremy Banks has pointed out) the icon shows "the other" site of the main/meta pair, and clicking on it is for switching to the respective other site. See the comment thread for some UI improvement ideas.

6
  • Where are you selecting them? The colors all appear to be correct for me.
    – animuson StaffMod
    Commented Feb 27, 2013 at 20:15
  • 1
    The icon beside "switch sites" isn't the currently-selected site, it's a shortcut to switch between a site and its meta-site. This has confused me many times, too. The interface could probably do with a tweak.
    – Jeremy
    Commented Feb 27, 2013 at 20:16
  • 1
    @JeremyBanks I see. Two suggestions for a remedy / improvement: 1. Changing the text to "Switch between meta and main:" or "Switch to [corresponding] meta:"/"Switch to [corresponding] main:". 2. Switching the order of the icon and the "Switch sites:" text (and recoloring the icon to show the current site) might be very useful. Because this is confusing, even though one can argue that it's "technically" not wrong right now. Commented Feb 27, 2013 at 20:18
  • 3
    Displaying both main and meta site icons side-by-side might avoid confusion.
    – user213400
    Commented Feb 27, 2013 at 20:20
  • 1
    That has confused me many times too.
    – bfavaretto
    Commented Feb 27, 2013 at 20:31
  • I was going to make the same question, and I saw yours (thought it was not possible that nobody had not seen this...:) ). I upvoted the question and all the comments (except the first one). It is really confusing the way it is. Commented Aug 5, 2013 at 21:10

1 Answer 1

5

I've created this pull request to resolve the issue based on the suggestion made in the comments.

Here is what it will look like when you are running a query on Super User:

switch to meta

And here is what it will look like when you are running for Meta Super User

switch to main

And this is what it will look like for sites without a Meta or Main site (currently only Meta Stack Exchange and Stack Apps I think):

switch sites

Am I missing a colon somewhere?

Either way: Allow for 6 to 8 weeks to get this reviewed, commented on, merged. Wait for a deployment of a revision > rev 2020.8.27.79.

Guess what happened? This is now deployed and live in rev 2020.12.13.80.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .