0

The automatic retrieval of the title of questions via URLs in bullets does not work on SO. The long form does. It works here on meta (I've checked). Problem?

marked as duplicate by Tim Stone, psubsee2003, Rory, hims056, Lance Roberts Apr 3 '13 at 3:23

This question was marked as an exact duplicate of an existing question.

  • Did you check with an answer link on Meta? – Arjan Apr 2 '13 at 21:10
  • (As an aside: note that referrals don't work when used on the sites themselves; hence there's no need to leave your user id in that URL.) – Arjan Apr 2 '13 at 21:11
  • @Arjan, no, I checked with a question. My user id is nowhere in that URL. – kolossus Apr 2 '13 at 21:13
  • 1
    The 1530938 in http://stackoverflow.com/a/3406631/1530938 is your used id. And I guess short links to answers are not auto-expanded? – Arjan Apr 2 '13 at 21:15
  • @Arjan Wow. Is this by design? I just hit the share button. Why's my uid relevant? – kolossus Apr 2 '13 at 21:17
  • See Privacy leak in permalink? for that user id. – Arjan Apr 2 '13 at 21:18
  • @Arjan, understood. So this is by-design then? – kolossus Apr 2 '13 at 22:46
  • I tried to find some official reference, but only found my own footnote in a post form December 2011. So, I don't know what is expected. That said: short links to answers don't seem to work here on Meta either. – Arjan Apr 2 '13 at 22:50
  • @Arjan I imagine it's expected that all links work, but short links to answers don't contain the question ID, so they require special casing (or an API change) – Tim Stone Apr 2 '13 at 23:33

Browse other questions tagged .