See this question on Ask Ubuntu: What are the key combinations for alphabets 'ऋ' and 'ॲ' on Hindi Bolnagari keyboard layout?

I am talking about Unicode Character 'DEVANAGARI LETTER CANDRA A' (U+0972). There seems to be rendering issues with it. The character displays perfectly fine in the raw input (ie; the body, title, comments - all in edit mode) but doesn't render correctly when posted. This happens everywhere - title, body, comments.

Examples: renders correctly in inline code but it is displayed as ॲ normally.

ॲ is also displayed correctly in Code Block

Wrapping it in <kdb> tag renders it correctly on AU but not on Meta.SO -- .

This is how it looks at my end:

its look at my end

I am using Firefox 19.0.2 on Ubuntu. Character Encoding is already selected as Unicode (UTF - 8). Is it happening only to me?

  • 2
    Works for me. Chrome Stable on Ubuntu 12.04. Apr 4, 2013 at 17:57
  • @Manishearth: Yes.. Just tested myself on Chrome.. Works well at my end too.... Looks like the problem is with Firefox...
    – Aditya
    Apr 4, 2013 at 17:59
  • Works for me on FF 19.0.2 on Ubuntu as well. I haven't installed any extra fonts except those that you get prompted about during the installation/updates. Apr 4, 2013 at 18:02
  • @Manishearth: I haven't installed any other fonts as well.. I would upload the image of how it renders for me.
    – Aditya
    Apr 4, 2013 at 18:04
  • 1
    Looks fine on IE
    – yoozer8
    Apr 4, 2013 at 18:42
  • Looks fine here
    – Cole Tobin
    Apr 4, 2013 at 19:49
  • Works for me on FF 20.
    – nneonneo
    Apr 4, 2013 at 20:05
  • Works for me on FF 19.0.2, Windows 7.
    – nhahtdh
    Apr 5, 2013 at 16:09

2 Answers 2


Encoding is not the problem, since you see the character in some instances.

The problem is clearly in the font your browser is using and in particular:

  • It works when matching Consolas, Menlo, Monaco, 'Lucida Console', 'Liberation Mono', 'DejaVu Sans Mono', 'Bitstream Vera Sans Mono', 'Courier New', monospace, serif;

  • It fails when matching Arial, Helvetica, sans-serif;

  • It fails again when matching Arial, 'Liberation Sans', 'DejaVu Sans', sans-serif;

The problem is likely to be the default fonts on Firefox, which you can change - or you can install Microsoft fonts or Apple fonts.

For more info: (Ubuntu -Firefox- default font) How make default font arial in Firefox on Ubuntu 10.04?

  • I followed AskUbuntu's link and installed ttf-mscorefonts-installer. Thereafter changed the default font in Firefox to Arial. See the image. However, I still face this problem. It didn't have any effect whatsoever. Do I need to make further changes using the Advanced option for Fonts? If so, what should I use?
    – Aditya
    Apr 5, 2013 at 18:58

This means that either your browser isn't reading the page with the right encoding or your system doesn't have a font with that character.

  • I have checked the encodings. BTW, encoding and fonts shouldn't matter at all since the Unicode Character renders perfectly fine when used inside inline code or a code block. See the image that I have uploaded in question.
    – Aditya
    Apr 4, 2013 at 19:51
  • Encoding does matter as the surrounding <pre> blocks help the browser separate the byte sequences.
    – Cole Tobin
    Apr 4, 2013 at 19:53
  • I have UTF - 8 already selected as encoding (this is already default on Firefox). See the image: i.stack.imgur.com/EabUG.png
    – Aditya
    Apr 4, 2013 at 20:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .