8

This question is regarding meta.serverfault.com. I'm posting it here because I can not post it there.

I am logged in (can post questions and answers) but I can not up vote (even though I gained the privilege) and I can not even mark question as favorite (i see: "Please log in or register to favorite this question.").

I CAN post questions on serverfault but I CAN NOT post questions on meta serverfault.

There is "finish signup" link on the right of my user name in top menu and sometimes there is a message on the very top which says: "Finish signing up by setting a password for your account".

I tried to click "setting a password" and did set password (log in with Stack Exchange box) few times. I also passed the same track clicking "finish signup" but I still get this message.

I tried to log out and log in again - does not help.

It happens only on serverfault and I do not experience anything like that on stackoverflow.

I think it is a kind of bug in web application...

UPDATE: I tried to delete cookies for serverfault but it does not help either.

UPDATE: I use Firefox 20 with NoScript but I have enabled all sites for serverfault.

UPDATE: I logged out from serverfault and then did "clear your recent history" and checked all checkboxes. It also deleted all my cookies. Still the same...

UPDATE: I am quite convinced that this is some bug in application as I tried to log in with Safari AND Chrome without ANY plugins and the same thing happens. Moreover I logged in with Safari and Chrome with other browsers closed (to prevent any interaction).

UPDATE: Yes, I have enabled stackauth.com and sstatic.net in my Firefox noscript configuration.

UPDATE: I tried from another PC (Firefox without any plugins) which also uses other internet connection... still wants me to set the password and does not stop even if I do so, even if I set different password.

  • Try clearing navigator cache to be sure. Do you have any extension installed on your browser? – Hugo Dozois Apr 12 '13 at 12:58
  • This could be resolve by simply clearing cache and cookies (it looks like one of those things). Also, you're certain that your browser is not blocking JS, cookies or local storage on either site? – Tim Post Apr 12 '13 at 12:59
  • 1
    Have you also enabled stackauth.com in your noscript configuration, as well as sstatic.net? – Tim Post Apr 12 '13 at 13:08
  • 1
    Im having the same problem and i've had it for almost a year, no luck on trying anything – Skyler 440 Apr 16 '13 at 16:14
  • Did you try to ask developers/owners of this platform for help? I already flagged this post asking for fixing this issue but no answer so far... – Mike Apr 16 '13 at 19:17
3

To be honest, we don't really support NoScript (and other extensions of the kind). We depend heavily on Javascript, but we don't maintain a handy list of domains or anything like that that should be whitelisted. So, even if you get your setup working, anything can break at any time.

Here's a partial list of domains that you'll want to whitelist:

  • ajax.googleapis.com
  • cdn.mathjax.org
  • cdn.sstatic.net
  • stackauth.com
  • google.com

There may be others. We're also experimenting with different CDNs right now, which is throwing another wrench into the whole thing.

With all that said, your Meta Server Fault account is showing up as "unregistered" for some reason. That should be fixed now. Give it another shot and let me know if you're still running into problems.

|improve this answer|||||
  • This issue was not actually related to NoScript (at least in its last stage) as, as I wrote in updates, the same thing happened in all other browsers without any plugins. The only way it could be related to NoScript is, if during first interactions with the site, my NoScript filtered some traffic so the registration process stuck in some way... Anyways, thank you very much. It is all OK now. :) – Mike Apr 18 '13 at 21:27
  • @Mike yeah, I just figured I'd cover all the bases. Glad to hear everything's fine now! – Adam Lear Apr 18 '13 at 21:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .