This question already has an answer here:

I'm experiencing trouble with OpenID sign-in on site.

What are the needful steps that can help on troubleshooting OpenID login issues?

Return to FAQ index

marked as duplicate by animuson support Sep 19 at 15:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Based on our experience, these steps can help troubleshooting OpenID login issues.

  1. Are you behind a proxy or firewall? OpenID requires very long URLs and proxies / firewalls with aggressive settings will sometimes block OpenID accidentally. This has been documented a bunch of times, often in corporate settings. If so, try without the proxy/firewall -- or convince your network admins that OpenID is in fact safe to allow..

  2. Have you modified the default cookie policy in your browser? OpenID, and our login process, requires cookies to be enabled and match the default settings that browsers ship with. If you have modified the cookie policy in your browser (or even worse, have disabled cookies altogether) this can prevent logins from working.

  3. Have you tried clearing your domain cookies? Sometimes the cookie information gets corrupted somehow (not quite sure what happens here) but clearing cookies for the domain in question (,, has been known to work.

  4. Have you tried in a different browser? The world is lousy with great browsers, and switching out browsers can quickly tell you if there's something "wonky" with your browser plugins, configuration, etc.

  5. Are you able to log in to other sites that support OpenID? Lots of sites now support OpenID including big ones like Facebook. Does your OpenID work there?

  6. Does your OpenID profile have invalid information in it? This is quite rare, but we have seen instances where profiles with problematic info (like invalid / gibberish email addresses) cause exceptions on our end. If possible, try a new, default OpenID or switch OpenID providers just for testing.

  7. Is your site especially slow to respond? In order to prevent denial of service attacks, it's common for OpenID libraries to have cutoff times of a few seconds when making HTTP requests. If you're delegating, try putting your delegation on a blank, plain vanilla HTML "hello world" page to remove any processing delays.

  8. Do you use a self-signed SSL certificate? Because self-signed SSL certificates, if generally accepted, would allow DNS poisoning or other network attacks to enable identity spoofing, we do not support them.

  9. Is your HTML valid? If you are OpenID delegation, something as simple as a missing opening <head> tag will cause an OpenID login failure but you won't necessarily know it from viewing your site in a modern browser. Check your HTML for validity.

Check your OpenID

There's also a diagnostic page which might give you more information about any potential problems:

After using the above page, check the "recent logs" link to see what is going wrong.

Bonus Round

Don't wait until after something goes wrong to set up an alternate OpenID in your profile.

  • Just want to add to point 6: My account missing the nickname SReg field which prevented me to log in from my SimpleID server. There should probably be a list of SReg fields required by StackExchange servers. – ntninja Jul 21 '13 at 20:07
  • Web site is currently unreachable. Let's hope it will be back soon. – Laurent.B Dec 28 '13 at 11:52
  • is unreachable. One of these should read "Is your provider Yahoo!?"; I've had this problem before (and right now), and Yahoo! is the problem. ( is a 404 right now; if you go to you can use the link it provides to log in.) – Thanatos Sep 19 '14 at 4:00
  • Tried everything but no success. Then just tried to change yahoo's url from to and it Voila!!! it worked! – N-JOY Sep 22 '14 at 7:37
  • 8/ "Do you use a self-signed SSL certificate?" - do you consider letsencrypt as self-signed? (it definitely seems so :/) – Tomáš Kafka Mar 17 '17 at 10:10

protected by animuson Nov 26 '13 at 1:11

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .