3

When reading code that is a one liner and is wide enough to scroll, the Mac's scrollbars that appear is too big makes it hard to read the code, that is behind it.

For example:

Difficult to read

It's not impossible but for UI its not good.

What can be done to address this problem?


NOTE: This might not reproduce on othe people's macs. I am using a Magic mouse with a 2011 iMac running Mac OS X 10.8 Mountain Lion.

Test:

1234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890
  • 4
    Do you have any suggestions on what to do about it? Basically, this is a usability problem with OS X, not Stack Exchange. – slhck Apr 27 '13 at 15:14
  • You haven't mentioned a browser at any point - which is usually the culprit rather than your OS (unless you've customised the life out of it's UI) and your browser can't cope. – nickhar Apr 27 '13 at 15:17
  • @nickhar: True - Firefox draws its own scrollbars that avoid this problem completely but for a browser that uses native scrollbars this is a problem which I can reproduce on my Mac when I enable autohiding of scrollbars. – BoltClock's a Unicorn Apr 27 '13 at 15:42
  • @nickhar I am using Safari – Anish Gupta Apr 27 '13 at 16:11
  • @slhck I think we should make the code box a bit larger for browsers that use native scroll bars or turn them off if you can – Anish Gupta Apr 27 '13 at 16:12