9

I'm getting a "Unable to rollback to the current revision" alert box when clicking on the rollback option of the revision 2 of the post below:

https://stackoverflow.com/posts/16379886/revisions

Update: Right now, no error message is shown, but no rollback is made either.

@JasonC (comments) also reports a problem: "Same issue trying to roll back to revision 4 of https://meta.stackexchange.com/posts/251659/revisions (currently at revision 5)"

12
  • Something with the suggested edit being linked to the next edit (they improved it). Why they did that baffles me...
    – animuson StaffMod
    May 4, 2013 at 23:43
  • 1
    My best guess is that, since the suggested edit was never actually applied to the post, it was merged with the next edit. Since it was never applied, it can't be rolled back. Still, that's strange behavior...
    – user206222
    May 4, 2013 at 23:49
  • 1
    @animuson Probably shouldn't have edited that post :/ now it's not reproducible here.
    – user206222
    May 4, 2013 at 23:49
  • Yeah, and the latest editor didn't really added the "Thanks" back in. I believe their edits overlapped, that is, like @KnightswhosayNi said, the revision 2 never really got through (@BobJarvis edited before it was approved).
    – acdcjunior
    May 4, 2013 at 23:53
  • @acdcjunior The edit was automatically approved when Bob Jarvis improved it, and marked the edit helpful. So, the edit was technically approved, though it was never applied.
    – user206222
    May 4, 2013 at 23:56
  • @KnightswhosayNi Hm, I see! Now after @ animuson's edit, rollback on revision 2 gives... nothing. Just a reload(?) on the page. Should we try to roll back to 3, then 2? I don't know, things are getting messy now... :(
    – acdcjunior
    May 4, 2013 at 23:57
  • @acdcjunior Can you still not rollback to 2?
    – user206222
    May 4, 2013 at 23:58
  • @KnightswhosayNi Yes, when I click on revision 2's rollback, the page is reloaded (some Ajax POSTs are made before the full reload) and nothing happens. Haven't tried to click on revision 3's rollback, though.
    – acdcjunior
    May 5, 2013 at 0:07
  • 1
    That's weird. I just tested this, and I can't roll it back either. This is definitely reproducible.
    – user206222
    May 5, 2013 at 0:08
  • Same issue trying to roll back to revision 4 of meta.stackexchange.com/posts/251659/revisions (currently at revision 5).
    – Jason C
    Mar 20, 2015 at 13:55
  • What a strange, strange edit...
    – Zizouz212
    May 29, 2015 at 20:53
  • Tried rolling back stackoverflow.com/posts/834270/revisions from revision 3 to 2 but failed with same error message. Manually copied from 2 to make 4, then it allowed me to rollback from 4 to 2 which makes no changes.
    – Pang
    Sep 22, 2015 at 3:01

0

You must log in to answer this question.

Browse other questions tagged .