0

I wanted to edit a post. This is a screenshot of before the edit:

The post's view before edit

Then I clicked "edit" button. Astonishing, this post lost it's beauty. Below is screenshot of after clicking edit button:

Post's view after edit button clicked.

Why did this happen? Should I format all this from scratch?

PS: link to post used in screenshot.

  • 6
    No repro. What browser are you using? – Bart May 13 '13 at 15:14
  • Not reproducable in Chrome latest beta. – Niels Keurentjes May 13 '13 at 15:16
  • I took a screenshot in Firefox 15.0. After your comment, I also checked in Chrome 26.0.1410.64 m. Result is same. – Ikrom May 13 '13 at 15:19
  • The link you added leads to the accepted answer, not the question. – Ren May 13 '13 at 15:20
  • @bob: can't repro with that exact version of Chrome. Did you try clearing your cache? (And make sure you didn't disable JavaScript.) – Mat May 13 '13 at 15:26
  • @Ren Thanks, I updated the link with more correct one. – Ikrom May 13 '13 at 15:27
  • Check the loaded JavaScript files. Are any failing to load? Could be that one is being blocked by your browser/provider/employer causing this issue. – Oded May 13 '13 at 15:27
  • @Oded, @Mat My JavaScript is enabled. All js files are loaded. I've seen this issue multiples times with many posts while editing. I've adblock on my browser and while checking console I saw WebSocket connection to 'ws://sockets.ny.stackexchange.com/' failed: Unexpected response code: 502. I don't think it's cause to error. – Ikrom May 13 '13 at 15:36
  • 3
    Assumptions are the mother of all.... does it work when you disable your freeloading-kill-all-website-revenue-so-they-can't-survive plugin? – Niels Keurentjes May 13 '13 at 15:53
  • Disabling adblock didn't help. I was using a proxy. I turned it off. Cheers, editing posts is showing like a charm in Chrome. However, disabling adblock, proxy not helped in Firefox. So now, Chrome shows well, but Firefox has same issue. – Ikrom May 13 '13 at 16:30
  • 1
    Are you sure FF is not still using the same proxy, or that FF is not using a stale version of the JavaScript? – Oded May 13 '13 at 16:33
  • @Oded You're mentor. I cannot believe I missed that. I needed to configure separately each browser. I disabled proxy in FF, now edit posting is working as expected. I don't know why that happened. Thank you. Can you answer with your thoughts? I'll accept that. – Ikrom May 13 '13 at 16:46
2

The symptoms you have seen and the fact that others were not able to reproduce point at an issue on your end - something is blocking some of the JavaScript.

From your comments, it appears that you are using a proxy that is blocking web sockets (which we use a lot here on Stack Exchange, for various things), causing the issue you have seen.

Unblocking web sockets (either by disabling this proxy or another way) should solve the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .