80

The "meta" link (and FAQ and chat links) has disappeared from the top navigation bar of Stack Overflow all sites in the network...

enter image description here

I'm feeling quite lost at the moment. Additionally, I could create separate "Missing"/ "Wanted" posts for the FAQ, and Chat links as well, but I think you get the drift...

45
  • 22
    rev 2013.5.17.689: the day the meta died.
    – user7116
    Commented May 17, 2013 at 19:38
  • 4
    On the bright side if I'm wrong about where the OT questions on meta come from this might stop them.
    – Flexo
    Commented May 17, 2013 at 19:40
  • 8
    Eeeeeeeeek!!!!! Commented May 17, 2013 at 19:42
  • 9
    Shog broke it
    – Taryn
    Commented May 17, 2013 at 19:43
  • 11
    To be honest, I'm not 100% sure how I found my way here. No, I'm serious. Really! (was just coming to say something about that!) Commented May 17, 2013 at 19:43
  • 5
    Thank goodness I have the metas bookmarked
    – Luke_0
    Commented May 17, 2013 at 19:44
  • 32
    All right, what smarty is making code changes on Friday afternoon right around beer-thirty?
    – Aaron Bertrand Staff
    Commented May 17, 2013 at 19:45
  • 6
    @Lix - No one cares about the links to chat or faq? No one reads the FAQ Commented May 17, 2013 at 19:48
  • 4
    @bluefeet Shog has an alibi, he was in ServerFault chat.
    – tombull89
    Commented May 17, 2013 at 19:50
  • 3
    @Oded was the first SE dev to show up here, therefore it's his fault.
    – yannis
    Commented May 17, 2013 at 19:50
  • 9
    What ever happened to read-only Fridays?
    – MDMarra
    Commented May 17, 2013 at 19:52
  • 8
    If any post deserves an EEEK!, it is this one.
    – user102937
    Commented May 17, 2013 at 19:52
  • 6
    @Lix - just because they visited it for the badge doesn't mean that read it ;) Commented May 17, 2013 at 19:53
  • 14
    Instant rep-cap. Congratulations on all the new unicorn dollars you are receiving for this question.
    – user102937
    Commented May 17, 2013 at 19:55
  • 6
    @RobertHarvey - Are you telling me there are some technical people who use Stack Overflow?
    – Oded
    Commented May 17, 2013 at 19:58

2 Answers 2

43

Spot the bug:

bool showNormalNavigation = IsMetaSite && !User.IsAnonymous;

Damn you, De Morgan!

Yeah - should be:

bool showNormalNavigation = IsMetaSite || !User.IsAnonymous;

Edit:

And yeah, my fault. Thanks Kevin for fixing!

14
  • 12
    Someone must feel quite the Bool
    – Zelda
    Commented May 17, 2013 at 20:06
  • 7
    Oded must be put on the Wheel of Blame!
    – Luke_0
    Commented May 17, 2013 at 20:07
  • 2
    Maybe you forgot to read this? :) stackoverflow.com/questions/2848184/or-and-operator
    – bfavaretto
    Commented May 17, 2013 at 20:10
  • 7
    Didn't you break something yesterday too?!? Maybe it's time for a day off! :)
    – Taryn
    Commented May 17, 2013 at 20:10
  • 1
    I should down vote for the error. But then karma would kick my puny little ass, so +1 instead! Commented May 17, 2013 at 20:12
  • 1
    +1 Now the world feels right again ;-) Commented May 17, 2013 at 20:12
  • 15
    This is simply a meta rep scam! 1) Introduce bool error hiding an often clicked component 2) Wait for meta to blow up 3) Post answer, saving the day 4) Go to 1) Commented May 17, 2013 at 20:28
  • Granted, there is photographic evidence that he writes code using only one hand...that's bound to go wrong some day....
    – Bart
    Commented May 17, 2013 at 20:43
  • 2
    @Bart - If that's the trouble I get into writing with one hand, imagine the trouble I would get into using two...
    – Oded
    Commented May 18, 2013 at 8:37
  • @FrankstonRalphingtonIII - You got me. Question is, what are you gonna do about it?
    – Oded
    Commented May 18, 2013 at 8:47
  • @Oded I just want in on the scam! Commented May 18, 2013 at 17:45
  • 1
    @FrankstonRalphingtonIII - Step 1: get hired by Stack Exchange. Step 2: Get your hands on the source code. Step 3: Checkin bugs. Step 4: Profit!
    – Oded
    Commented May 18, 2013 at 18:17
  • 1
    Still doesn't seem right. On [meta.so] when not logged in I don't see a link to "main". From the expression IsMetaSite || !User.IsAnonymous this doesn't look intentional? Commented May 21, 2013 at 8:28
  • @MartinSmith - Good catch. I thought it was fixed as I outlined above, but the actual commit was... different. Truly fixed now.
    – Oded
    Commented May 21, 2013 at 10:32
8

The link was drunk, it seems to have wandered back home now. Next time this happens we shall stage an intervention:

enter image description here

7
  • 1
    -1 18 seconds in? Tough crowd, today.
    – tombull89
    Commented May 17, 2013 at 20:03
  • 2
    Perhaps people think the link was only buzzed, and not drunk?
    – enderland
    Commented May 17, 2013 at 20:03
  • Strange thing is: I'm already rep-capped. I can't earn more meta reps from this anyway :P Commented May 17, 2013 at 20:05
  • 2
    @Manishearth: "Oh, in that case..."
    – Matt
    Commented May 17, 2013 at 20:05
  • 10
    -1 not enough jQuery
    – Lix
    Commented May 17, 2013 at 20:05
  • 4
    @Lix: ah, now THAT'S a downvote reason I can understand :P Commented May 17, 2013 at 20:06
  • -1 the eyes are not freehand
    – Doorknob
    Commented May 17, 2013 at 20:50

Not the answer you're looking for? Browse other questions tagged .