7

As a moderator, when I delete comments in a post, if I delete all the comments manually (not hitting 'purge all', the 'add comment' dialog disappears after I've deleted the last comment, and there is no 'add comment' link to click on.

I've tested it here on meta to reproduce the issue.

  • I see this as a regular user as well. Meant to report it after careful testing it wasn't any Greasemonkey script. Create the first comment on any post, start to add a new comment (so the text box is there), then delete your first comment again. – Martijn Pieters May 21 '13 at 12:30
  • I've experienced this on my mobile phone as well. – Jack May 21 '13 at 12:33
  • +1 for finding a bug, though I wonder if it would have been better to do it on non-live data? A comment of mine on that question disappeared into the ether... – halfer May 21 '13 at 12:33
  • 1
  • @ShaWizDowArd not really a dupe (since there's no answer there), and mine also shows that the 'add comment' link that would normally appear on a post without comments disappears. That's missing from the other. Completeness man, completeness. – George Stocker May 21 '13 at 12:35
  • 1
    @halfer Also: Remember, Comments are ephemeral. Oh, wait... I just figured out how to fix the comment problem on Stack Overflow! Write a bot that randomly deletes all the comments in a post, and then leaves a comment that say, "Comments are Ephemeral." It's GENIUS. – George Stocker May 21 '13 at 12:37
  • When that other bug will be fixed your bug will also be fixed, hence the dupe IMO. – Shadow Wizard is Ear For You May 21 '13 at 12:39
  • Wow. I found another bug. That's somewhat weird. meta.stackexchange.com/questions/181150/… – George Stocker May 21 '13 at 12:40
  • 2
    Stop breaking stuff @GeorgeStocker. See, this is why we can't have nice things. – Bart May 21 '13 at 12:43
  • @Bart No, mainly @​​​​​​​​​​​​​​​Oded breaks stuff (as in here and here) :P – Doorknob May 21 '13 at 12:46

Browse other questions tagged .