I can't login in Stack Overflow using my Stack Exchange account from Firefox 21. This happen both in Windows 7 and GNU/Linux (Ubuntu 12.04 LTS 32-bit). I don't have any problem to login in Stack Exchange or other websites as:

Apparently the issue is only with http://stackoverflow.com.

When I try to login I'm sent to the homepage. I can't see any error message unfortunately. I've seen other users are suffering a similar issue, but related with the use of AdBlock Plus. In Windows I'm not using AdBlock Plus. I will try later today to disable it on Linux and see if that helps.

Any idea of what can cause this malfunction? In Google Chrome everything works smoothly.

  • Have you tried logging into meta? May 22, 2013 at 16:34
  • 1
    Yes, I can access without any issue apparently. The only problem is with Stack Overflow.
    – Gianluca
    May 22, 2013 at 16:35
  • See also SO not letting me login?. That could easily be the same issue. (If so, that question is a duplicate of this, rather than vice versa.) May 22, 2013 at 18:19
  • 1
    I think we have a similar issue, but I'm not able to replicate it on Google Chrome. Apparently it affects me only on Firefox (my version is 21) both on Windows and Ubuntu 12.04 LTS. I've also tried to disable AdBlock Plus on Firefox, but the problem persist. In Google Chrome, with AdBlock Plus running, I can login perfectly in Stack Overflow, and related websites as unix.stackexchange.com and tex.stackexchange.com
    – Gianluca
    May 22, 2013 at 20:46
  • 1
    I'm seeing the same issue. And I haven't installed any ad blockers. May 23, 2013 at 13:51
  • I also am having this problem. Again every other SE site is fine only SO. I get the usual "Welcome Back your logged in as John F. Miller redirecting you." message, but I go back to the non-logged-in page. When I try to ask a question, I get an infinite loop of redirects. Jun 21, 2013 at 4:39

1 Answer 1


I had the exact same issue with Firefox 22 on OS X 10.8.4 after an import of all my data (history + cookies + bookmarks etc.) from Chrome.

Removing all cookies from Firefox solved the problem.

In my case, I'm logging in SO with my Google account, so maybe removing only the SO / Google cookies would have worked. Did not use a very subtle approach here. Eh.

  • 1
    Yes, removing only the SO related cookies also works.
    – adrianp
    Jul 8, 2013 at 12:36
  • here what is full form of So ,i mean SO stands for??
    – user254160
    Mar 3, 2014 at 8:18
  • @AnkitAgrawal StackOverflow. Mar 3, 2014 at 8:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .