14

I've been having trouble getting to cdn.sstatic.net all day. It's been crippling not to be able to play Stack Exchange!

Chrome's resource panel was showing 'host not found' for cdn.sstatic.net.

I think I've tracked it down to this:

I have IPv6 connectivity and my machine is querying for AAAA records first. Here's how it goes:

[michael@challenger:~]$ host -t ANY cdn.sstatic.net 8.8.8.8
cdn.sstatic.net is an alias for sstatic.net.cdn.cloudflare.net.

OK, a CNAME, let's follow that:

[michael@challenger:~]$ host -t AAAA sstatic.net.cdn.cloudflare.net 8.8.8.8
Host sstatic.net.cdn.cloudflare.net not found: 3(NXDOMAIN)

Whoah! That's not good. NXDOMAIN means that domain doesn't exist. That's not right. Let's try a different domain to see what should be happening:

[michael@challenger:~]$ host -t AAAA serverfault.com 8.8.8.8
serverfault.com has no AAAA record

Not sure what exactly is going on here, but someone needs to fix something.

Could be lame referrals: http://dns.squish.net/traverses/90336bfcff65c12ee97d57f05e0ce2df/detail

  • Last I checked, StackExchange doesn't support IPV6, so they wouldn't have an AAAA record. This question, for instance, is still status-deferred. Also, see here. – Aza Jun 1 '13 at 3:35
  • 5
    The problem isn't that no AAAA records exist. The problem is that the CDN DNS servers are returning NXDOMAIN ("the domain doesn't exist"), not "no records of that type". – MikeyB Jun 1 '13 at 3:36
  • FWIW, I had a lot of trouble getting files to download from the CDN this morning, but I haven't had any troubles since I got them downloaded. – animuson Jun 1 '13 at 3:37
  • The same thing happens with a type A query, too. One of CloudFlare's DNS servers is on the fritz. The thing is, IPv4-only people won't notice because the other DNS servers are returning responses. But people with IPv6 (like myself) will have more trouble because of the bad response for the AAAA query. – Michael Hampton Jun 1 '13 at 3:44
  • Absolutely a DNS problem. – Sinthia V Jun 1 '13 at 3:54
  • 2
    We have been making some changes in this area; I've flagged this up to the perpetr... er, I mean: developer involved – Marc Gravell Jun 1 '13 at 5:01
  • 2
    lol It's been crippling not to be able to play Stack Exchange! – Pëkka Jun 1 '13 at 6:03
  • I hope you meant flogged @Marc – Pëkka Jun 1 '13 at 6:04
  • @Pekka웃 working remotely, I can only flag, not flog; I need to save up the flogging until I next see the team. – Marc Gravell Jun 1 '13 at 6:09
  • 1
    @MarcGravell Developer? It's an ops problem! :) – Michael Hampton Jun 1 '13 at 6:09
  • @MichaelHampton - never heard of devops? – Oded Jun 1 '13 at 8:05
  • CloudFlare is looking into the issue...unfortunately the lack of IPv6 on many of our teams' ISPs make it difficult to repro and debug. – Nick Craver Jun 1 '13 at 14:23
  • 2
    The only winning move is not to...aww, yeah, okay. – tombull89 Jun 1 '13 at 14:53
  • 5
    @Oded Heard of devops. Never seen it done right. – Michael Hampton Jun 1 '13 at 16:56
  • 1
    @NickCraver: he.net and sixxs.net both offer free IPv6 tunnels, simple to setup and run. – user147520 Jun 1 '13 at 17:50
4

This was actually an edge case we hit with our CDN. We've enabled IPv6 support on our CDN, which should resolve the issue for the time being. We'll continue to monitor the resolution of these DNS entries for both A and AAAA queries.

  • 1
    Just in case it helps: I'm on IPv6 too, and I did NOT get any problems, from Amsterdam. – Arjan Jun 4 '13 at 17:16
  • Learned something new today, but I don't know if it means anything ;-) When I run host -t ANY ... with my own provider, I only get IPv6 addresses (if available). Like host -t ANY sstatic.net.cdn.cloudflare.net only gets me IPv6 addresses. But with Google, I get both IPv4 and IPv6, like host -t ANY sstatic.net.cdn.cloudflare.net 8.8.8.8. The Google output matches the output of NOT using -t ANY with my own provider. Again: it might not mean anything, but who knows ;-) (So far, I was always using -t AAAA to force seeing IPv6.) – Arjan Aug 11 '13 at 17:00
  • And though I have no problems, nslookup -type=AAAA cdn.sstatic.net on my Mac shows Non-authoritative answer [...] just fine, but also an EMPTY line after Authoritative answers can be found from:. Same when using Google, nslookup -type=AAAA cdn.sstatic.net 8.8.8.8 (Again, no idea if it implies anything. Using host -t AAAA cdn.sstatic.net does not give me any clue about authoritativeness at all.) – Arjan Aug 12 '13 at 15:54
  • I am currently having this problem. I am having to disable IPv6 on my network adapter in order to access stack overflow. – Lewray Sep 25 '13 at 10:59
  • 1
    Test test test test – Geoff Dalgas Jun 7 '14 at 23:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .